Showing results for 
Search instead for 
Did you mean: 


Super solver

When I tried to log into my virgin media account  today  using the microsoft edge browser,  the captcha  security kept preventing me from logging on  several times, and indicated a wrong user name or password, so I double checked the password and it was correct, but it still kept failing several times.

It does not help that the captcha images required several attempts each  time and kept  failing, and also at time losing connection indicating waiting. Some of the images are complex and require many selections.

I eventually tried the google chrome browser and logged on  first time, it is not uncommon for edge not to login to VM, I will do a clean on the edge browser.



Accepted Solutions

Hi ALF28,

Thanks for your update. In that case, it does sound like a browser issue and we would recommend to use Google Chrome if you're experiencing issues with Edge, but we'll keep this in mind if we come across any other customers with similar issues.

Kind regards


See where this Helpful Answer was posted


Forum Team
Forum Team

Hi ALF28,

Thank you for your post. I'm very sorry for the issue you've been having. 

Have you been to preform the clean and successfully access the account?


Thanks, I did a clean of the edge browser which just seemed to hang for ages so I repeated the clean which did not complete, however I was able tog in as it no longer remembered my user name so had cleaned.

Also when using the VM community today, after loggin in, edge  then logged me out when I tried to answer the post, requiring another login to contiue.

I think there is some connectivity issues using edge, so I will reset the edge browser to default settings and see how that goes.

It is perhaps better to use google chrome for reliability?


Hi ALF28,

Thanks for your update. In that case, it does sound like a browser issue and we would recommend to use Google Chrome if you're experiencing issues with Edge, but we'll keep this in mind if we come across any other customers with similar issues.

Kind regards


Thanks, I have both windows 10 and windows 11 laptops.

Both are logging in using chrome.

The older windows 10 laptop is running slow between 10 mbps and  54mbps download speed on wifi, so it could be my own wi-fi router, and the fastest was 54mbps, not much better on cable.

My windows 11 laptop is has a faster connection as high as 87mbps today on cable.

The chrome browser seems better and connects well to log in.

Connection issues may also also be down to speed fluctuations on wi-fi.

Hi ALF28,

Thanks for coming back to us and for the additional information.

Are you currently in modem mode? I've had a look to see if there's any signal issues on our end, however your equipment is showing as unreachable. If you could please ensure your Virgin Media Hub is turned on and in router mode, that would be great - we can then run some diagnostics for you.

Let us know 😊


Thanks for the reply, yes i am in modem mode hub3 , I have done my own checks and the Hub 3 system logs all look fine and wi-fi speed over 70mbps today.

My VM hub may have been switched off preventing the tests as I have been away from home or power turned off.

However today I can not log in to VM on any browser due to a captcha issue-see this other post today

Re: virginmedia website account are down? not app ... - Virgin Media Community - 5418792

Thanks for coming back to us @ALF28 

I can see on your post in that thread you linked you're trying a windows 10 restart after it's updated and running a virus scan. 

Can you also confirm if you get the same or have similar log in issues from the app at all? 

Please do keep us updated with how you get on after these restarts and checks. 

Here to help 🙂
Virgin Media Forums Agent

My laptop computer restart, following a windows  10 update consisting of 3 updates has sorted out my issue, I have now logged in to my virgin media online account to ckeck my VM web email using google chrome. The updates cause the browsers to malfunction untill a restart is done.

There is another windows 10  update waiting to install now.

The virus scan did not find anything.

I have not used the app, not sure it works on my old tablet.

The computer was also running slow before the restart, I think the computer can lock some functions after an update and then needs a restart, but there was no promt, I only found out by looking at windows setting -update, I do not have auto restart after a windows update.

It has sorted my own present issue thanks.

Update-However after posting this I lost wi-fi connection for some reason and had to switch to ethernet cable so my own router wi-fi stopped working, not a VM issue as it is my own router so I will check it out, it is secured but not connected, it may need a restart.

A restart of both the hub 3 and my own router has not fixed my wi-fi issue, I can connect only by ethernet cable.

Also something is going on,my landline phone has been crackling and tinkling today and not working or receiving call, says user busy and no dial tone just crackles.  Good job I have a mobile phone.

I will check the service status for my area and report back.

Service status for my area indicates no faults on tv, phone and broadband.

update-dial tone returned and can make calls but not receive calls, I just get crackling, busy or even stranger voices that sound like a call centre. I will ring 150. The phone has been making odd noises fro a few days.

i will check my calls record.

VM are in the process of disconnecting my landline and they are sending me an adapter for the hub that will arrive in 2 days, this was unexpected so the landline phone is not working properly for a few days. I had no phone call, letter or email regarding this change over.

The connectivity issue with laptop wi-fi appears to be specific to my windows 10 laptop, my other windows 11 laptop connects to wi-fi, perhaps a restart  will fix this I hope.