Menu
Reply
clarendon23
  • 12
  • 0
  • 1
On our wavelength
555 Views
Message 1 of 33
Flag for a moderator

DEF01 Error When Registering Account

We're new Virgin Media broadband customers, and the service has been up and running for a few weeks now.

I've been trying to register for a Virgin Media account but have been having several problems.

To begin with I got a DEF01 error after putting in the email address we used to set up the service, but tried a minute later and proceeded to the next step. It accepted our customer number and area code, but when I wanted to use a different email address for the account it wouldn't accept an email address that started with a number, so I set up a new email address that it was happy with and proceeded to the next step of setting the password.

No matter what password I used (even up to 64 characters in length) it said I couldn't use that password and I had to try a different one, without specifying why I couldn't use the password I'd chosen (randomly generated by a password generator).

Now whenever I try to register I just get the DEF01 error when putting in the original email address and cannot progress any further.

I've tried multiple email addresses (even ones that aren't registered with Virgin) and get the same error.

I've tried multiple browsers, including private/incognito mode, and cleared out browsing history.

Can anyone help? It seems like the Virgin Media account registration process is fundamentally flawed judging by the number of other posts on here with the same issue.

Thanks

0 Kudos
Reply
seanmac
  • 7
  • 1
  • 1
Tuning in
542 Views
Message 2 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Exact same situation and patience is running thin. It's clear it's a server side issue outside of our control either with everyone or with a large subset of users. An acknowledgement of that fact would be nice instead of being asked to clear cookies / try a different browser. 

Dreamcatcher230
  • 4
  • 0
  • 1
Tuning in
517 Views
Message 3 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Also had the exact same situation. 

 

Just set up my package today.

Been unable to register for a new account for days now and had the exact same problem as yourselves. "Can't use this password" now to the DEF01 error code. 

Tried calling the service team who weren't any wiser as to what the issue is.

 

Frustrated to say the least.

Tom_W1
  • 2.22K
  • 105
  • 223
Forum Team
Forum Team
513 Views
Message 4 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Hi @clarendon23 and @seanmac thanks for your posts although I'm sorry to hear of your concerns raised.

I'm going to send both of you seperate PM's as we're likely going to need to raise IT Tickets for you both to get this issue sorted.

Both - please expect the PM's to arrive shortly and respond directly when you can!

Many thanks

Tom_W
0 Kudos
Reply
clarendon23
  • 12
  • 0
  • 1
On our wavelength
500 Views
Message 5 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Thanks for reaching out @Tom_W1. I've responded with the information you asked for.

0 Kudos
Reply
Dreamcatcher230
  • 4
  • 0
  • 1
Tuning in
493 Views
Message 6 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

As mentioned in the thread, I also have the same issue @Tom_W1 

0 Kudos
Reply
Tom_W1
  • 2.22K
  • 105
  • 223
Forum Team
Forum Team
472 Views
Message 7 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Hi @Dreamcatcher230 thanks for your message and sincere apologies.

I'm going to send you a PM now asking you to confirm all the necessary details to take this further.

Please expect this PM and reply when you can!

@clarendon23 - I'm in receipt of your PM and we're collating all of these at the moment. Please be assured I'll come back to you tomorrow as per all other customers in this same position - many thanks for your patience so far.

Many thanks

Tom_W
0 Kudos
Reply
clarendon23
  • 12
  • 0
  • 1
On our wavelength
423 Views
Message 8 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Tumbleweeds blow across the scene...

Tags (1)
0 Kudos
Reply
Chris_W1
  • 5.05K
  • 221
  • 325
Forum Team
Forum Team
417 Views
Message 9 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

Hi clarendon23, thanks for the message, Can you delete the cache and cookies and an alternative browser to see if you are still getting the issue? Does any change when you try registering with a different email address? ^Chris

0 Kudos
Reply
Marion52
  • 10
  • 0
  • 0
Tuning in
413 Views
Message 10 of 33
Flag for a moderator

Re: DEF01 Error When Registering Account

@clarendon23 I resorted to calling the helpline/support and eventually after a couple of attempts Virgin reset my password from their side, they gave me the details, I entered them from my side and result it all worked.

So painful as it is, it might be worth calling them as all of the suggestions regarding clearing cache, use different browsers etc didnt work for me.

I called the helpline about 8.30pm at night and got through within 5 mins.

 

 

0 Kudos
Reply