Showing results for 
Search instead for 
Did you mean: 

'Complete your profile'

Joining in

Hello all, 

I have a Virgin bundle package but since this was ordered last month I have had extremely limited access to my account.

Every time I try to use my account I am presented with the the 'Complete your profile' form (security question, DoB & mobile number). Once I have completed that it states 'You’re all set!', but then when I click sign in it takes me back to this. 

Each time I start this process I receive an email link, which likewise leads me to the same infinite loop.

I have noticed others have reported similar issues but in their case it was a blank form.

Hoping this can be fixed as soon as possible.


P.S. Now that I am just about to post the message I am getting a 'Bad request' server message when I try and click the email link.


Hey cleighton297, thank you for reaching out and I am sorry to hear this, also a warm welcome to the community 

Please can you make sure you are trying to make an online account with the correct details and you are in private mode when trying to make one, I find Google Chrome works.

Try a different password. Certain things are too guessable to be allowed. No special characters, only letters and numbers, MUST begin with a letter, try keeping it between 8-10 characters. 

Please keep us updated. cheers 

Matt - Forum Team

New around here?

Hi Matthew,

I have also had the same problem for the last couple of weeks, have tried multiple different browsers with and without private browsing and have had the complete your profile page return every time.

if you can look into this it would be much appreciated

Hi there @Ant11 

Thank you so much for your post and welcome to the community forums, it's great to have you here. 

I am so sorry that you have faced this issue and thank you for posting. Can I just check have you been able to try this specifically on Google chrome and have you also ensured you are meeting the correct password criteria? 

Yes have tried on Google Chrome.

I can’t change my password to remove special characters and make it between 8-10 characters as that is deemed too weak a password. Please advise on what else I can do 

Forum Team (Retired)
Forum Team (Retired)

Thanks for the response there,

So just to clarify are you able to actually sign into MyVM?



Yes I can technically sign in (I have an account and am registered) but I keep getting asked to “Complete my Profile” every time I sign in so cannot change my account settings etc as I get locked into a never ending spiral of Complete my Profile pages

Forum Team (Retired)
Forum Team (Retired)

Ahh okay, thanks for the response there.

Has this been a recent account creation?



around 20 days ago

Thanks for confirming, sorry to see that you've still been having issues with your online account.

It would be best to have this checked further, I'll send you a PM to confirm your details so this can be done.



The do's and don'ts. Keep the community welcoming for all. Follow the house rules

hi same issue