Showing results for 
Search instead for 
Did you mean: 

Cant register for account

Tuning in

I've tried 25 different passwords, some actual words, some random, even some using a password generator. All meet the requirements (of varying strength to moderate/strong). No special characters.

I've tried Safari, Chrome, incognito mode, iPhone, iPad, Virgin Media app to create an account.

No matter what I try, I always get "You can't use that password. Please choose another."

Never used the email address with VM before, only to place the order. I've been given an install date, and the email states to login to My Account if I'd like to change it. I have all my account details, but cannot get beyond the registration process where it asks me to create a password.

What am I doing wrong?





this issue still not resolved, having exactly the same issue as a new costumer. My broadband is all up and running but still cant set up online account.

Hi @liligarcia, thanks for posting and welcome to our community.

I am sorry that you've been unable to register your online account.  I would love to help you resolve this.  I am going to send you a private message.  Please look out for the purple envelope in the top right of your screen.





Joining in

I am having this same issue for about 4 weeks, using the correct password criteria.

I have spoken to 6 different people at Virgin media and they have done nothing!

It is really annoying something so simple yet so challenging, can someone help me get this resolved please.

Hi ManiD85,


Thanks for posting and welcome to our community 🙂


I'm sorry to hear you're having some issues registering for an online account. I've had a look at things from our side and can see there is an IT ticket with the team.


I'm sorry for the delay in fixing this.



Hi there,


I've been having the same issue. Nothing seems to work. Are you able to help resolve this please?

Hi Alex, any idea when they will be in touch. Its been dragging a while

I am sorry for this ManiD85,


There are no updates on this currently, but the team will be working to resolve this asap.



I'm having the same problem. Trying to register for my VM and can't find a password that is accepted. All passwords I'm trying are in line with the guidance. I've had my service set up today. 


Hello Rcrisp. 

This is a known issue that we are looking to have a fix for very soon. 

Sorry for any inconvenience this may have caused you. 



im having the same issues - has there been an update on when this will be fixed?