Menu
Reply
Jordan02
  • 2
  • 0
  • 0
Joining in
240 Views
Message 1 of 4
Flag for a moderator

Cannot register for an account - password not allowed

Good evening,

 

I had virgin media installed today (ordered around a month ago), and have been unable to register for an account. No matter what I try, I get "You can't use that password. Please choose another."

I cannot stress enough, I have tried various passwords, they all say I meet the requirements, but still the message is the same. I have tried to contact customer service through whatsapp, they forwarded me to technical support some 3 hours ago and I've heard nothing since. 

I have seen that others have has this problem on this forum, but none of the "solutions" work. I am seriously at odds here, and it is NOT a good start to life with virgin media.

I would appreciate any help that isn't along the lines of telling me the requirements (I know them off by heart now!) and not trying different internet browsers or apps,I have tried them ALL.

 

Thanks

Tags (2)
0 Kudos
Reply
Zoie_P
  • 5.28K
  • 218
  • 409
Forum Team
Forum Team
201 Views
Message 2 of 4
Flag for a moderator

Re: Cannot register for an account - password not allowed

Hi Jordan02, 

Thank you for your post and a warm welcome to our community 🌞.

I am sorry you are having issues with getting registered with us, can you let me know if you have tried using a different browser and cleared all cookies 🍪?
Keep us posted and pop back if you are still having issues and we can further assist you here.

Zoie

0 Kudos
Reply
Jordan02
  • 2
  • 0
  • 0
Joining in
190 Views
Message 3 of 4
Flag for a moderator

Re: Cannot register for an account - password not allowed

Yes I have tried absolutely everything. 

0 Kudos
Reply
Zoie_P
  • 5.28K
  • 218
  • 409
Forum Team
Forum Team
181 Views
Message 4 of 4
Flag for a moderator

Re: Cannot register for an account - password not allowed

Thank you for popping back, I am sorry these steps have not worked 😓

I am more than happy to take a look for you and see if we can get you registered.

I will pop you over a PM to get some details, so keep an eye out for the little envelope 📩

Zoie

0 Kudos
Reply