cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot login to virgin media account in browers

xwang
Tuning in

Hi

I've been trying to log into my virgin media account through different browsers with no success. I have tried chrome, edge and firefox. After typing in my login details, it's just always the loading page and can't proceed further. I have access to the virgin media app and login details on the app are fine. I want to get on the website on the browser so I can change the security setting, e.g. parental controls etc. of my broadband. Can someone give me some advice on how to solve this problem, please?

This is the never ending loading pageThis is the never ending loading page

 

15 REPLIES 15

Hi @GoldFishSnuggle thanks for your messsage and sorry you're still having issues with this.

Can you please try via ethernet cable and if this happens on mobile data too?

Please keep us posted.

Many thanks 

Tom_W

Hi @Tom_W1,

Same thing happening when trying to log in using mobile data (again, on both phone and when hot-spotting to laptop). I don't have an adapter to connect my laptop to ethernet cable so am unable to test that right now - would have to buy one to do so later which I'd love to not have to do.

Thanks!

 

 

Hi Tom, 
Here's every combination and variety I have tried:

  1. Chrome Browser + Wifi
  2. Chrome Browser + Wifi + Incognito
  3. Firefox + Wifi
  4. Firefox + Wifi + Incognito
  5. Chrome Browser + Wifi + Different Account (Cognitio and Incognito)
  6. Chrome Browser + Ethernet (Cognito and Incognito
  7. Mobile Phone through My Virgin App + Wifi
  8. Mobile Phone through My Virgin App + 4G Mobile Data

At this point I highly recommend contacting someone that can check everyone's accounts here as I would imagine because it happens after we log in, that there is some security setting on our accounts that is getting confused and thinks that we both do and don't have access to get into Account Settings areas.

Get back to me if you need any more details. Getting some good speeds on that internet connection now that I'm plugged in my laptop to the ethernet as expected, so gonna install my entire steam library in the meantime and see what's faster.

If it helps, I also just tried to reset my password to see if that affected anything and I got told that I cannot reset my password because "you do not have additional details setup." 
No idea what that means but my account is under the same email address as this user, so maybe you can supply that additional tidbit to ask what's going on.

Soundy
Joining in

Me too, to all of the above.

I eventually went through to the interactive chat via the mobile app and whilst they were not able to fix it, they were able to change the setting I needed changing.

The problem still remains however.

Abbie24
Joining in

Still had no fix on this. Tried to call customer services so that they could turn ChildSafe off but was just transferred to 3 different people over 50 minutes and none of them could do it for me. Please can this be fixed by the end of the day so we can login online and sort it out ourselves.