Showing results for 
Search instead for 
Did you mean: 

Cannot login to virgin media account in browers

Tuning in


I've been trying to log into my virgin media account through different browsers with no success. I have tried chrome, edge and firefox. After typing in my login details, it's just always the loading page and can't proceed further. I have access to the virgin media app and login details on the app are fine. I want to get on the website on the browser so I can change the security setting, e.g. parental controls etc. of my broadband. Can someone give me some advice on how to solve this problem, please?

This is the never ending loading pageThis is the never ending loading page



Joining in

I am also experiencing this. I tried on 3 separate devices as well as multiple browsers and after signing in details, the loading screen is all I see.

If it helps I only just got my box yesterday, and I registered yesterday if this is a new customer issue for your QA team or developers to isolate what occured.

Forum Team
Forum Team

Hi there @xwang 

Thank you so much for your post and welcome to the community forums, it's great to have you back.

I am so sorry that you are facing this issue with your account and are unable to log in via the site. 

Can I ask if you have been able to try via an incognito browser at all? 

Joining in

I am also having this exact issue. I can log in fine on the app but cannot log in online. After I type in my login details it gets stuck on the loading page and can't proceed further. I have tried on multiple browsers, tried clearing the cache and tried using incognito mode - none of which worked.

I'm so sorry that this is also happening to you @Abbie24 and thank you for trying all the possible fixes first. 

I'm going to pop you a PM so we can take a closer look into this. I will pop you a PM across now, please keep an eye out for the envelope at the top of your screen alerting you to a new message.

Joining in

I tried incognito mode in 2 different browsers. Neither got me any further than the infinite loading screen to answer Ashleigh_C's question.
Although one did get me a "Help Us Improve our Website" widget pop-up. However as a professional QA, I will avoid giving another sassy issue ticket to one of your devs.

Please help though.

Hi @GeekCallum thanks for your reply and sorry that this is still ongoing for you.

Do you know if this happens on mobile data for example, or is it just on your home WiFi where this isn't loading for you?

Please keep us posted.

Many thanks


Hi Tom,
Already tried that. I get a loading screen for infinite again, but I get taking to an greyed out screen on my phone where I can see "Account Settings" page, except nothing is filled out and everything is non-interactable.
On PC and Laptop I don't get that, I just get a white background behind the infinite loading logo.

Hi @GeekCallum thanks for your reply.

I'm sorry it's not quite clear based on your response if this is affecting both mobile data and WiFi, is this correct? Can you try via ethernet cable too please?

Many thanks


Joining in

Hi All,

Having the exact same issue on all browser types (chrome, safari, etc) across all devices (laptop, phone, etc). Logging-in on the app works but there are many things where the app redirects you to the browser, so need to be able to sort this out.

Same as GeekCallum I am a new customer that only got my box a few days ago and having registered haven't been able to get into my account since.