cancel
Showing results for 
Search instead for 
Did you mean: 

Can't register password

jessd1
Tuning in

I have tried making an account after buying your services for the last 2 days. It keeps stopping me at the password asking me to register a different password but nothing works.

I have tried using different devices, different browsers, clearing cache and cookies, using different passwords. I cant access customer service because it requires an account already.

Pls help I am losing my sanity

8 REPLIES 8

jessd1
Tuning in

For people who might be interested for me APPARENTLY it's because I haven't had my services installed yet

Hi @jessd1 

Thanks for posting and welcome to the community. Sorry to hear of the online account registration issue.

Please can you try using incognito mode / private browsing to see if that fixes it?

Also, the email address you're wanting to use for your username, have you used this before with us on a previous account? If so, that's a Move and Transfer process that can only be done when you are installed.

Best wishes.

John_GS
Forum Team


Need a helpful hand to show you how to make a payment? Check out our guide - How to pay my Virgin Media bill

Hi John,

I have tried using incognito but that didn't work either, and it's the first time I'm setting up with you so I havent used that email before. (Its also a different email to what Im using for this account)

I am sorry to hear that.

Please can you let me know what error message it is giving you?

Please can you try to make an account on Google Chrome and no other browser if possible please? Thanks 

Matt - Forum Team


New around here?

I have tried to make the account on google chrome, and the error message I keep getting is "Sorry, there was a problem registering that password. Please choose a different one." I've tried loads of different passwords and all of them have met the requirements. I tried weak and strong passwords too.

Hi @jessd1 👋.

Thanks for updating us. It sounds like you are caught in a glitch on the website, in order to sort this out for you, we would need to bring you into a private message so that we can get this resolved. Please look out for the envelope on the top right of your browser, or if you are using a mobile device, it will be located under your profile icon. 

Thanks.

Sabrina

Hello, can you help me too? Same problem and tried everything

Hi @majdy100 👋 Thank you for your post and welcome to the Virgin Media Community 😀

We're sorry to hear about the problem you're having 😔

I can see my colleague has sent you a private message via another thread. Please respond to his latest message at your earliest convenience.

Regards,
Daniel