Showing results for 
Search instead for 
Did you mean: 

No incoming calls to landline - Is my Panasonic cordless handset KX-TG7321E compatible?

Joining in


I'm a new VM customer & first time poster to this forum. I also have limited technical knowledge and understanding. 

VM failed to arrange to port my existing landline number over so the engineer couldn't check the landline worked when he set up my broadband & Stream box.  It was only much later that I realised the landline didn't work.

I've had a frustrating time trying to get customer services (CS) to help me resolve the issue of not receiving any incoming calls on my landline. Incoming calls go straight to an answerphone. There is no ringing at either their end or on the landline. Outgoing calls appear okay at the mo but it's been a bit hit and miss & I've had to reboot the Hub 3.0. since speaking to CS earlier this afternoon.

Before ringing CS I'd done multiple reboots, worked my way through the help guides, checked all leads/cables were in, the phone cable was plugged directly into Tel 1 of the hub (there was no need to use the adaptor supplied), and that there are no service issues locally.  CS undertook various tests, passed me on to the second line technical team who then told me my handset was the problem, even though I can make outgoing calls. I don't have a spare handset to try or borrow which is what they advised. I'm trying to save some money by switching to VM, not fork out for a new handset.

Can someone tell me if my Panasonic cordless handset KX-TG7321E is compatible with VM please? And if it is what I need to do next.

In hope & gratitude for whatever help you can give.


Forum Team (Retired)
Forum Team (Retired)

Hi SpectreWest, 

Welcome to the Community and thank you for posting. 

We are very sorry to hear of your experience and the problems you have face with the landline service. 

I am afraid we do not have a list of compatible handsets to check your equipment against. 

Do you have an alternative handset that you could test on the line? 




Alessandro Volta

No reason the Panasonic phone should not work as far as I can see. Manual is dated 2008 so should be OK. The default final answer from the hopeless offshore phone support is to blame the handset.

Some general comments would be ...

When you say incoming calls go to answerphone, do you mean VM voicemail or the answerphone on your cordless system? If you want to use your own answering machine on the cordless system, you presumably want VM voicemail turned off or the two will conflict.

Test the line with an alternative handset, no need to buy one, see if you can borrow one from a friend, family member, neighbour etc. Alternatively try a super-simple corded phone from the likes of Argos for about £10-ish - always handy to test a line at its most simple level to see if working or not (bypassing any other possible problems with cordless phones so not a wasted purchase as it can be used in the future).

When you get a new VM landline, VM gives you a temporary number so you can phone in/out. When your actual number is ported, the temporary number is replaced by the ported number. Do you know what the temporary number is (by dialling out to a mobile)? Once you have the temporary number, have you tried dialling in using that and does the call ring through and connect? Sometimes the number port gets 'stuck' and calls are not routed through to your phone line correctly (often you can dial out but not in)

Finally, if you are not using the VM adapter, where did you get the RJ11 to RJ11 lead from to connect the phone base to the VM hub? Sometimes the internal wiring of the leads can vary for different purposes and may not connect through from one end of the lead to the other. The VM hub's TEL1 socket uses the centre two pins of the RJ11 connector and the phone base will, most likely, use those too. So you need a connection from the centre two pins on each end of the lead to the other. For a RJ11 connector made of clear plastic, you can often see the colours of the internal cable cores to check you have this through-connection (centre two pins to centre two pins on each end)

If your Panasonic phone came with a lead which has the BT plug on the end, try that in conjunction with the VM adapter.

If you are still expecting/waiting for a number port, my guess is your number port is possibly not completed correctly/fully.