Menu
Reply
blackfive
  • 38
  • 0
  • 1
On our wavelength
178 Views
Message 1 of 4
Flag for a moderator

Installation Nightmare

In desperation here as ordered a phone line to go with the existing broadband I have and it's become a nightmare.

I confirmed that it was to run off the socket on the back of the router and was told all new installations do as they don't install traditional lines anymore. So I went ahead and ordered the line online. Then I get a message that an Engineer will call (which he did yesterday) which puzzled me if nothing required other than plugging it into the back of the router. The Engineer arrived coming in with a big bag of tools asking if I had a master socket and I said I had but as I had a DECT phone there was no need to wire anything in. He then agreed with me and plugged in the converter to the back of the router then plugged the phone into that. He made a few phone calls (cursing India!) then informed me that the line will be up and running with the number ported over later that day. Nothing happened!

This morning I rang Virgin and was informed, after a very long discussion, that the line would be enabled, working and the number ported over within 3 hours. Over 4 hours later and nothing had happened! I rang again and was passed from customer services to technical support saying that they would be able to sort it out for me but they then said that couldn't be done as it was down as a traditional phone line and asked me to plug it into their wall socket. NO! How could I when it doesn't exist? But took a long time to get this fact over to them. Now they said they couldn't do anything and only customer services could sort it out. This was quickly becoming a joke but it was real. So back to customer services who said they couldn't do anything in the usual broken poor English you can hardly understand. The girl then said I hadn't arranged for the number to be ported over. Untrue! So said she'd arrange it but would take up to 7 days from when I applied for the line so I told her it was then overdue so needed to be arranged immediately. After another long discussion not getting anywhere I was passed back to technical support who said they'd arrange for the line to be connected within 3 hours. Still nothing as the line still dead! They were going to arrange for the number to be ported over and the line went dead cutting me off and no one has rung me back so after over 2 hours of calls and speaking to numerous people I'm no further forward.

Does anyone have the contact details of someone I can speak to high up in this joke of a company to get this sorted? Also they need to get rid of the India call centre and bring it back to here where we can understand what people say.

 

Tags (2)
0 Kudos
Reply
Hayley_S
  • 1.43K
  • 45
  • 107
Forum Team
Forum Team
167 Views
Message 2 of 4
Flag for a moderator

Re: Installation Nightmare

Hello @blackfive,

 

Welcome back to the community page, thank you for posting on here.

 

I am sorry for the experience so far with us.

 

I have managed to locate your account using your forums details, I can see that you have an appointment on there, can you see this on your side? 

 

Look forward to your response. 

Hayley
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
blackfive
  • 38
  • 0
  • 1
On our wavelength
147 Views
Message 3 of 4
Flag for a moderator

Re: Installation Nightmare

Hi Hayley,

As far as I'm aware and been informed the only appointment was on Thursday 22 July and that was when the Engineer confirmed what I already knew that no wiring was needed leaving me with an adapter to enable the telephone to be plugged into the back of the router. I seem to get nowhere with this as no one appears to be taking ownership of it to sort it out and get the line working. It's still not working! Two days and phone calls being passed to different people and no further. So far a very poor service.

0 Kudos
Reply
Molly_G
  • 1.08K
  • 50
  • 135
Forum Team
Forum Team
120 Views
Message 4 of 4
Flag for a moderator
Helpful Answer

Re: Installation Nightmare

Hey @blackfive,

 

Thanks for your response - sorry that the number still hadn't been ported.

I would like to take a look into this for you but just need to confirm some private details with you first. Please keep a look out for the purple envelope at the top of the screen.

 

Many thanks,

Molly_G
Forum Team



New around here? To find out more about the Community check out our Getting Started guide