cancel
Showing results for 
Search instead for 
Did you mean: 

Caller Id shows calls from "No Number" every 2 hours

rnmh1964
Tuning in

I have been having continual problems with my landline since it was connected to the hub and WiFi. At the moment my caller ID on the phone continually shows that every 2 hours I am receiving a call from "no number" and this occurs over a 24 hour period each and every day. The phone does not ring so that is not the issue, more that I am concerned that there is a problem with the actual phone line as when the engineer came to install it, what should have taken a few minutes took much longer as it didn't set up at first. I have spoken on the phone with a Virgin representative who says these frequent "No number" calls are not showing at Virgin's end so my handset must be faulty. Well it ISNT because I have purchased a brand one and the exact same thing is happening! I now have to scroll back through about 18 missed calls to see if someone has genuinely tried to ring me. I am concerned that there is an error on the line. Thjs never occurred when the line was connected to the socket. Please rectify this or at the end of my contract I will be looking elsewhere.  The fault is definitely NOT with the handset 

1 ACCEPTED SOLUTION

Accepted Solutions

Zach_R
Forum Team
Forum Team

Hi @rnmh1964,

Thank you for your post and welcome back to our community forums. We're here to help.

I'm really sorry to hear you've been facing some issues with your Caller ID function recently, and that connecting a different handset also hasn't helped to alleviate the issue. I've checked our systems on our end, and I'm unable to detect any issues on the line that would explain this problem for you.

Are you facing any issues with your broadband (wired or wireless/Wi-Fi) and other devices connected to it, or is it only the Caller ID function?

Thanks,
 


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!


See where this Helpful Answer was posted

27 REPLIES 27

Zach_R
Forum Team
Forum Team

Hi @rnmh1964,

Thank you for your post and welcome back to our community forums. We're here to help.

I'm really sorry to hear you've been facing some issues with your Caller ID function recently, and that connecting a different handset also hasn't helped to alleviate the issue. I've checked our systems on our end, and I'm unable to detect any issues on the line that would explain this problem for you.

Are you facing any issues with your broadband (wired or wireless/Wi-Fi) and other devices connected to it, or is it only the Caller ID function?

Thanks,
 


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!


rnmh1964
Tuning in

I have no other issues with the wifi or other devices at all and this has only started happening since the phone line changed from the socket to the hub connection. It just seems like too much of a coincidence. Its just annoying to have to scroll through so many supposed missed calls to see if anyone has genuinely rang me. Can you confirm for definite that there is not any issues with the line please?

Hi @rnmh1964,

As advised, I've been unable to detect any issues on the line currently that would explain this. Have you attempt to reboot the router itself at all to ensure that's not causing the problem for you? Can you also confirm any other checks and troubleshooting you've done thus far?

Thanks,
 


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!


I have tried rebooting the router and purchased a new handset as advised by Virgin. Is there anything else I can try please?

Hi @rnmh1964,

Thank you for giving that a try. I'm really sorry to hear that this sadly hasn't helped.

I'm going to send you a private message in a few moments so that we can take some additional details and investigate further. Please respond to this at your earliest convenience and we can go from there.

Thanks,
 


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!


Crystalgazer
On our wavelength

Hello.

Did you get this resolved? I have the same problem since moving to a hub 5 and it seems to have affected quite a few people.

 

There is another post about this under Constant 'no number calls' since moving to IP Telephone from landline (Home)

Hi @Crystalgazer

 

Thanks for your response

 

Sorry to hear about your issue, are you able to advise if you're experiencing any issues with the WiFi / Broadband at all or is this the only issue at hand?

 

Regards

 

 

Travis_M
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


Hi, yes I did get it sorted eventually. I had to really push to get an engineer to visit but when they did I was told it was a common fault with the Hub 5. I asked to have my previous hub model back and the issue stopped straight away.

Glad you are sorted. I have asked if I can have a hub 4 back. Can but see what they do. I am being asked for more info at the moment.