Menu
Reply
dv2529
  • 89
  • 2
  • 8
Dialled in
715 Views
Message 1 of 11
Flag for a moderator

Caller ID not working properly for months

Hi, my caller id display suddenly (mostly) stopped working - but this was ages ago.  I rang support at one point and was told all looked fine but it has been very intermittent - most calls just say "Incoming Call" but then the odd one will show the number.  I rang support again last Saturday and 2nd line said they can see no problem, removed caller id and readded it etc,  and they ended by saying it must be my phone.  I plugged an old phone in and that also did not show the incoming numbers.

I have an engineer visit due tomorrow but looking on this forum I see that there seem quite a few people who were able to get the same issue quickly resolved by posting here - which might save your engineer a visit.

Thanks

Dave

0 Kudos
Reply
Serena_C
  • 2.19K
  • 91
  • 215
Forum Team (Retired)
Forum Team (Retired)
705 Views
Message 2 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Hi @dv2539

 

Thank you for your post regarding the Caller ID function not working for you, I'm sorry to hear that the issue has been on going.

 

I would like to take a look at your account and see if we can get this working. I shall send you a private message now to obtain the details required. Please look out for the purple envelope in the top right corner and get back to me when you can.

 

Kind regards,

Serena

0 Kudos
Reply
dv2529
  • 89
  • 2
  • 8
Dialled in
624 Views
Message 3 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Hi again,

I have called my home phone loads of times from my mobile and just don't usually see my caller number.   I have also plugged in my old phone in my house and that also isn't displaying incoming numbers.   I don't have another phone to try (and both my phones are Panasonic).

So anyway, the engineer came yesterday.... he said if the line sounds okay to his ear, and it rings when it is supposed to, there is nothing he can really do - he said they have no dealings with Caller ID.  I hoped he would at least have a phone with caller display he could plug in to test, but he didn't; in fact the basic phone he did have he said he had had to buy himself.  I'm amazed they don't even have basic equipment to check things.

This morning I rang my home phone multiple times each from 4 different sources (2 mobile networks, Skype for Business, and consumer Skype). - on the first attempt with each source the number was correctly shown on my landline phone (except consumer Skype that said "Number Withheld").   However, on multiple subsequent attempts from each, no information was displayed ... it just said "Incoming Call".    I have spoken to Panasonic who have said there is nothing functionality in the phone that would do that.

Please advise how I can progress this?

Thanks

Dave

0 Kudos
Reply
dv2529
  • 89
  • 2
  • 8
Dialled in
614 Views
Message 4 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Okay thanks - a local manager called and another eng will pop in next Wednesday with a test phone to get to the bottom of it.

0 Kudos
Reply
Sofia_B
  • 1.19K
  • 36
  • 99
Forum Team (Retired)
Forum Team (Retired)
609 Views
Message 5 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Thanks for the update @dv2529

 

I'm so glad to hear this 🙂 

 

Please keep us updated on how the appointment goes. 

 

Thanks, 

Sofia
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
dv2529
  • 89
  • 2
  • 8
Dialled in
444 Views
Message 6 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Hi,

Yes the engineer came some time back, confirmed it was an issue, went to the Exchange and confirmed still an issue (and I think he said it also applied to other local lines he tried). I think he said it might need to go to provisioning.

But of course I have heard nothing since.... thats another 3 months!!

However, I needed to use the 141 facility this morning, and I noticed neither it nor 1471 work either; it says "Sorry the service requested is not available from this line".   Does that give any clues as to the problem? -  it seems it is not just caller id missing, we seem to have nothing but a basic phone line with no extra features?!

Is there any way you can escalate this?

Dave

0 Kudos
Reply
Paulina_Z
  • 4.31K
  • 159
  • 327
Forum Team
Forum Team
436 Views
Message 7 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Hi @dv2529,

Thank you for your pos. I am very sorry to hear that this issue is still impacting you. 

Can you clarify is this is the same issue that has carried on since your last technician appointment? Was this issue ever fixed by the engineer? 

Please let us know so we can help.

Thank you.

Paulina_Z
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
dv2529
  • 89
  • 2
  • 8
Dialled in
431 Views
Message 8 of 11
Flag for a moderator

Re: Caller ID not working properly for months

That is right - we still have no caller id and this has not been fixed; the engineer could see it was an issue but said it needed someone else.   It was just that I have only just also noticed the other features are missing too, so thought their absence may give clues as to what is wrong.

Dave

0 Kudos
Reply
Travis_M
  • 3.86K
  • 139
  • 285
Forum Team
Forum Team
429 Views
Message 9 of 11
Flag for a moderator

Re: Caller ID not working properly for months

Hi @dv2529

 

Thanks for the reply!

 

When the engineer advised around this needing someone else, did they book this in or advise of any further steps regarding the missing feature(s)?

 

Please do keep us updated 🙂

 

Regards

Travis_M
Forum Team



New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
dv2529
  • 89
  • 2
  • 8
Dialled in
424 Views
Message 10 of 11
Flag for a moderator

Re: Caller ID not working properly for months

I think the suggestion was that he was a bit stumped and was going to go and talk to someone else, but he said it may need to go to [I think] the provisioning team.  So no, nothing booked in as such, as it was more a back end discussion he needed.     He definitely said it was not just my line that the caller ID was not functioning on.    It did used to work though.


Dave

0 Kudos
Reply