Showing results for 
Search instead for 
Did you mean: 

Xbox Remote Play

Joining in



I have an Xbox Series S which I’m having difficulty setting up remote play correctly.


When I was with Sky it worked perfectly over Wi-Fi. This time I’m connected directly to my Virgin Hub 3 router via Ethernet.


It will work perfectly in the house on Wi-Fi when connected to my phone but externally on 4G/5G or other Wi-Fi networks, it will not work. I just get the error “We can see your console but can’t connect right now. Try another Wi-Fi network or mobile data connection”


I’ve tried everything I can think of on the router, port forwarding and I’ve tested the Xbox and Xbox says yes, remote play will work. But nothing.


I’ve even tried to connect on my phone via VPN but still get the same message which is why I think it’s the Virgin Hub 3 blocking connections even though I’ve set up port forwarding with what I think are the right ports looking at Microsoft’s website.


Has anyone else had trouble or found a fix? Even if it’s a point in the right direction.


Many thanks


Dialled in

Yes. Still an issue. The problem is with the port forwarding. Some of the ports xbox needs you to setup with forwarding don't apply on the virgin router because an error comes up saying the ports are in use. Even though I know I haven't set them up to be used for anything else, the error still comes up. Its frustrating. The only solution seems to be is to buy a 3rd party router and use virgin router in modem mode.