Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

XBOXone DNS Server issue

Tuning in

Can anyone help me please, my sons xbox one randomly disconnected from the WiFi, when I tried to reconnect it I got the error message "DNS isn't resolving xbox server names" I've followed all the steps, reset router and xbox and manually entered DNS settings from my laptop and nothing is working πŸ€¦πŸΌβ€β™€οΈ ive connected it to my phones hotspot (which is currently connected to the wifi and not on mobile data) and that works perfectly fine, so i know that it's not an xbox issue



The XBOX is trying to connect to which Hub ( 3 / 4 / 5 ) ?

Check the Hub's signal is good at the location of the XBOX.   ( if possible a network cable would be better )

The default Virgin DNS are &,
if there is a need for a different DNS, the Google Public DNS and are a good start.

Sorry its a hub 3 (with 2 WiFi pods) I can't check the strength of the signal to the xbox as it just doesn't connect and ive done the signal test from the virgin app standing beside the xbox, results just said "good" I've tried those 2nd set of numbers previously to no avail.

When I reset the router and lost WiFi to my phone the hotspot stopped working on the xbox, my phone is further away from the router than the xbox, not sure if that's relevant or not 

If the hotspot serving the XBOX now does not work, that could be the first issue that needs to resolved.

Using a WiFi Analyser app on a mobile phone is a handy way to check the WiFi signal levels at the position of the XBOX.

As soon as my phone reconnected to the WiFi the xbox automatically connected back to its hotspot 

Very Insightful Person
Very Insightful Person

As noted already, it's most likely the wifi is the problem, the DNS is a side affect of this disconnect.

Can you not use the ethernet ports on the Pods, or worst case, get a good set of powerline adaptors for the XBox?  I'm assuming a direct cable to the Hub is not possible?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Hi S27cyb πŸ‘‹ welcome to the community! Thank you for posting. 

Sorry to hear about these issues with the Xbox connections. Huge thanks to the community for offering support so far! 

Would you also be able to clarify if the Hotspot the Xbox is connecting to is coming from the connection of your hub, or your mobile data?

Can I just check if you have tried deleting and forgetting the network from the Xbox directly, and then re-adding it? You can see more information on troubleshooting wireless issues on Xbox's here via their website πŸ‘‰ Troubleshoot a wireless network connection | Xbox Support

If at all possible, are you able to re-locate the Xbox so it can be tested with an ethernet connection coming from the hub, just so we can rule out any problems in this area?

Am I correct in understanding you have also been looking at the advanced settings in your hub to help manage this issue? (You can read more about this here πŸ‘‰ How to set up Virgin Media broadband in the 'advanced hub settings section') It may be worth checking that you haven't changed any settings to stop the X-box connecting to your hub directly. You can do this by logging back in and checking the individual device settings. If you need to completely re-set your hub's settings, you can do this via Pinhole reset. (Insert a pin into the hole marked 'reset' on the back of the hub for 60 seconds.) Please also bear in mind if you have Wi-Fi Pods the Xbox should connect to these under the same name as your hub rather than an alternative network name. You need to have Wi-Fi optimisation enabled and not have split Wi-Fi bands when using any Pods. 

I can send you a PM to offer further support with this if needed a little later down the line, but if you can let us know the answer to these questions first the community can also continue to help with this thread. 

Thanks for your patience whilst we get this sorted! I look forward to hearing your updates so I can offer further help. 

All the best. 


Hi Molly,


im having the same issue. VM want to charge me Β£50 to connect my Xbox to the server. I have tried resetting the router, forgetting the network on the Xbox, moving the Xbox to a better placement in the room but nothing works. 

the Xbox will connect to my phones mobile data fine but says there’s an issues resolving the dns server anytime I try to contact to my VM broadband.


can you please advise how to resolve this?

Hello Jaguarjaw


Sorry to hear of the errors connecting your Xbox to your network, we appreciate the frustration and you taking the time to run through the previous steps and raise this via the forums.


Is this via a wireless connection? Does it connect when wired? Are you using the Hub in modem mode with any other third party mesh systems at all? What happens when you run the tests via the Xbox console on it's connection?



Hi Rob,


it is wireless, it does work wired or connecting to other WiFi like at my families homes or via my mobile hotspot, I’m not using modem mode and when I run tests it says

β€œDNS isn't resolving Xbox server names

Unplug the power from your router or modem for 30 seconds, then plug it back in. Wait another 30 seconds.

When ready, check again.”


I’ve done this but nothing changes