Showing results for 
Search instead for 
Did you mean: 

Ubisoft connect connection lost

Joining in

So I'm going to start this off by saying that I've contacted Ubisoft for support in this and they've fully run out of ideas, They have recommended contacting my ISP which is Virgin Media and the only contact for them directly is by phone which isn't something I'm comfortable using so I will try here.

Now for the problem. Every time I try to play a game that uses Ubisoft Connect to log in it is unable to find a connection, Though I have no trouble with anything else using the internet. I have tried all of the troubleshooting steps from Ubisoft and have had no success with any of them. The only part of my setup that I have changed since this last worked is my Virgin Media Hub (upgraded to a Hub5), So I'm assuming it could be something to do with that though I really have no idea. I'm just hoping someone would have some idea on what to try because I'm at a loss to what to try now.


Alessandro Volta
Turn off websafe or change DNS to and

Forum Team
Forum Team

Good Morning @EvadRave, thanks for your post on our Community Forums, and a very warm welcome to you!

Sorry to hear of the issues with games that are manufactured by Ubisoft. 

Can you please confirm if you've been able to attempt the suggestion from @legacy1, on your router?

Kindest regards,


Thank you for the suggestions. I checked and websafe is already turned off, Changing the DNS does not seem possible on the Virgin Media Hub though I may be missing something, Unless you meant to do this on the pc which I'm having the problem on but I tried changing to a different DNS previously and this resulted in no change either.

Good Morning, I have indeed tried the suggestions and unless I'm missing something changing DNS does not seem to be possible on the Virgin Media Hubs.

Forum Team (Retired)
Forum Team (Retired)

Hi EvadRave 👋

Thanks for providing updates on this. To clarify, you can change the DNS from each individual device, but not through the overall Hub service - you would need to use a 3rd-party piece of equipment for something like this.

You mentioned no problems with any other service, but just to confirm, is Ubisoft Connect the only form of Multiplayer service you're unable to connect to? I've had a look on our side, and all of your services are within specification, but I can see that your Hub has been online for more than 20 days.

Can you please try performing a reboot by switching it off at the back for 30 seconds, before switching it back on again?


Reece - Forum Team

New around here? To find out more about the Community check out our FAQ


The problem is only with this one service, Nothing else has an issue.

I have just performed a reboot as you suggested and the problem still exists. 

Change the DNS on your PC or Game Console.

Thank you for the update @EvadRave 

Are you able to let me know if you are accessing Ubisoft via browser or app download? Also, have you tried the advice given by @Client62 


Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs

I have tried changing the DNS on my pc before and it didn't work then but I tried it again and still no joy. I am able to access Ubisoft via a browser but this doesn't allow games to be played as they require the Ubisoft Connect app which just errors showing a internet connection problem but with no indication of what it is.