Showing results for 
Search instead for 
Did you mean: 

Stoke-on-Trent xbox live issue

Tuning in

Was advised to post by Virgin Media on twitter, there is an area wide issue with Virgin Media Broadband in the stoke area, its actively interfering with Xbox Live connection.

This is only happening on Virgin media, works fine on every other method and supplier of connection.

I have done everything suggested, opening ports, switching my hub to a DMZ, resetting the hub, xbox, everything. 

It seems to be something to do with NAT typing, and Teredo. 

My only thought is that when I tried to open Port 53 as advised by both virgin media and xbox connection guides, it informed me that that port was reserved and couldn't be opened manually. System mess up somewhere that's reserved a port it shouldn't?


Joining in

I’ve from stoke on Trent and having the same problem phoned vm and they said there nothing wrong with there service 

Virgin media on Twitter and phone said nothing wrong, however a technician who came to the house to replace the hub has been in contact with me after I complained it didn't fix my issues that the team in the area are aware as multiple reports have been filed, and a ticket has been raised. 

Yet Virgin Media on twitter deny there's a problem and that no ticket has been raised. 

Tuning in

I too cannot log into xbox live virgin need to fix this but its a shame they wont even acknowledge it

Tuning in

I have also been getting the same issue on the Xbox Game Pass app on my PC since last Friday in the Stoke-on-Trent area, as suggested using a VPN as a workaround at least on a PC appears to work, this temporary fix is not as simple for consoles though.

The issue is affecting other services (Azure port connections, etc), and can be intermittent, so it is a wider issue than just Xbox services. 

The VM service status page for the area does highlight a known broadband issue as of yesterday but doesn't have any specific info, estimated fix is currently Wednesday 26th April @ 16:00, although this will likely slip as it has moved multiple times already.

Thank you for the information, hopefully it'll be solved ASAP or I'll send my xbox live bill to virgin 🙂

Tuning in

I'm having same issue too. Engineer came out couldn't fix the issue, but rang back later to say he'd received an email from his boss to say there is an issue. 

hopefully it'll get resolved soon

On our wavelength

Same issue since friday 21st april ST4 7QW


I had a virgin tech log in to my router remotely through my desktop to open all the ports - i keep repeating myself to them that something is blocking the xbox live servers.

Had a tech come to my house yesterday, didn't really understand the issue but sent a message on teams to other techs in the area to log the issue - plugged in a new router and nothings changed.


I have sent a complaint to VM that it is their problem not microsoft (please everyone send in complaints) and the fact i have just upgraded and started a new package with them for the 1gb internet so my kids can game online on their new xbox x which also cost me £650.


VM need to apply a non- CGN IP address and turn their NAT (Network address translation) to open and turn off a certain shield which is blocking xbox servers.


I have also logged in to my account and turned off the websafe settings but no avail.


considering i have only just entered a new contract in the last 2 months if the issue doesnt get resolved i will be talking to the financial ombudsman to see what i can do as VM are not providing the services we pay for.


Also like the idea of giving them my xbox live bill aswell i saw someone put 👍

Tuning in

Just a quick update, I had a text notification at around 8:30am this morning that stated the broadband issue in the area has now been fixed. 

But just checked, and the same issue connecting to xbox services (and other microsoft azure routing addressses) is still present, so no idea if the xbox issue we are seeing was related to issue there system was reporting, either way still no fix and also no real offical acknowledgement from VM's side that there is an issue.

My xbox live is working again is this the same case for everyone else