Showing results for 
Search instead for 
Did you mean: 

Rockstar Social Blocked?

Joining in


I've recently joined VM and when trying to access GTA Online, via my PS5, I get no access. This is the same for the Rockstar Social website. So seems any Rockstar related thing is being blocked. 

To test, I put my phone in hotspot mode, from mobile data and it loaded straight away. Same with the website. 

Can you please help out? Seems my IP is blocked for some reason, but no idea why. Thank you 


On our wavelength

If you've just joined, have you turned off the 'Child safe' setting? They're on by default - or atleast they were for me. 

You can access it from the My Virgin Media website > Update settings > Online security and toggling off 'Child Safe'.

I have these settings switched completely off. 

Just to add a bit more context, everything except Rockstar services works. Playstation network, other online games, all work great. 

The PS5 is plugged directly into the Hub 4 via CAT6 cable. Also tried on WiFi and got the same result. I have allowed the PS5 IP into the DMZ on the router and opened the required ports. 

Since I cannot access the Rockstar Social club website on my phone, and iPad, it seems my IP is blocked. 

Is there a chance of my IP being changed? Or am I going to have to put the Hub 4 in modem mode and buy a new router. Also to note, Rockstar services worked just fine through my previous ISP, TalkTalk.