Showing results for 
Search instead for 
Did you mean: 

PS5 doesn't connect to internet on boot - Have to wait

Tuning in


Apologies if this has been discussed elsewhere but I couldn't find anything.

My issue is my PS5 usually takes anywhere from 5 to 10 minutes to establish a connection to the internet and PS Network. I have a wired cable but this also happens on WiFi as well.

After a few minutes, instead of the failure message.  I start getting DNS error messages. I tried setting the DNS to and but this made very little difference.

Once the connection time is over, everything else seems to work - it's just annoying I have to turn on my console and wait before I can use it.

This happened on my 500mbps plan. I've just upgraded to a 1GB plan and it's still happening.

Every other device in my house works fine, including my PS4 - This only happens on my PS5

I read somewhere this could be related to IPv6 and I should disable it. Although there's no option on either my PS5 or anywhere I can find in the Hub to allow me to try this.


Any suggestions are welcome!


Tuning in

Just to add.. this has only been happening for the last few months. Everything was fine before then.

Forum Team
Forum Team

Hey SwagBag32,

 Welcome to the community and thanks for taking the time to post here on the forums.
I’m sorry to hear of the issues that you’re having with your connection at the moment, its strange that this would just be happening on the one device, has this always been the case since you have been since you started using your PS5 or has it worked for your PS5 in the past?

Kind Regards,


It was working fine when I first got my Ps5. This has been happening probably for the last 6 months or so. 

Another odd thing I noticed is that sometimes it hogs all the bandwidth as well, for example when it's waiting to connect... I can't use the WiFi on my phone for some reason, until the PS4 connects. 

Hi @SwagBag32 👋.

Thanks for the update. I too noticed this on my Ps5 recently using another internet provider, it was found that when doing a speed test and scrolling down further on the Ps5 menu on the Test Connection, the Ps5 kept latching onto the 2.4GHz connection. Have a check to see if yours is doing the same. 

We can assist in this and look further, we would first need to bring you into a private message. Please look out for the envelope on the top right of your web browser or if you are using a mobile device, it will be located under your profile icon.




The DNS error messages are a clue that the PS5 has not got a valid route to the internet.

As soon as the PS5 starts go and inspect its network settings i.e. the settings that have come from the VM Hub.

To work you need to see :

IP -           where xxx is 10 to 254 from the HUB DHCP server

Gateway -    the same IP as the VM HUB menu is the only value that can work.  
                 HUB 5 with a failed DHCP server sometimes gives out & this does not work.


DNS either the VM DNS or a Public DNS either is fine.