Menu
Reply
Sy1981
  • 32
  • 0
  • 4
On our wavelength
163 Views
Message 1 of 4
Flag for a moderator

Issues with connectivity to EA servers on PC

Hi all,

I keep getting a red packet loss icon when playing Battlefield V, and after troubleshooting with EA support they say its VM blocking the hops to the servers needed. 

I've done the required port forwarding on the Hub 3.0 and nothing also.

No issues when playing on Xbox.

Any ideas? 

0 Kudos
Reply
Serena_C
  • 284
  • 11
  • 32
Forum Team
Forum Team
91 Views
Message 2 of 4
Flag for a moderator

Re: Issues with connectivity to EA servers on PC

Hi @Sy1981

 

Thank you for your post regarding the issues you are experiencing when connecting to EA servers on your PC, sorry to hear you have been getting a red packet loss icon. I've taken a look at your Hub and your connection and there are no issues showing.

 

How are you connecting your PC to your Hub - via ethernet or WiFi?

 

Are you experiencing packet loss when you are playing any other games besides Battlefield V?

 

Please let me know,

Serena

0 Kudos
Reply
Sy1981
  • 32
  • 0
  • 4
On our wavelength
81 Views
Message 3 of 4
Flag for a moderator

Re: Issues with connectivity to EA servers on PC

Hi,

I eventually spoke to someone from your Technical support who advised the issue was the TP-Link Wi-Fi extender which the router does not like and in turn Virgin Media block ports while this extender is functioning. Removed and now working fine thanks.

0 Kudos
Reply
Serena_C
  • 284
  • 11
  • 32
Forum Team
Forum Team
78 Views
Message 4 of 4
Flag for a moderator

Re: Issues with connectivity to EA servers on PC

Thanks for letting me know @Sy1981 Glad to hear everything is now working fine for you 🙂

 

Serena

0 Kudos
Reply