Menu
Reply
Highlighted
  • 4
  • 1
  • 0
Tuning in
1,035 Views
Message 1 of 7
Flag for a moderator

Elder Scrolls Online Disconnects

I've been having problems with ESO including constant DC's about every 30minutes. I've researched this, and have been told to contact my ISP. Disconnects either happen at the end of loading screens or are random. I have also noticed very long loading times compared to other users. Apparently Virgin are aware of the issue.

I have tried a static IP, port forwarding, router resets, new PC hardware and from researching online, getting a new router with the latest firmware (or version of firmware that works with ESO) is the solution.

Could anyone help me out with this?

Regards,

0 Kudos
Reply
Highlighted
  • 4
  • 1
  • 0
Tuning in
1,014 Views
Message 2 of 7
Flag for a moderator

Re: Elder Scrolls Online Disconnects

Additional Information:

I have the super hub 2ac, possibly an upgrade to the superhub 3 may help.

0 Kudos
Reply
Highlighted
  • 1.64K
  • 87
  • 155
Forum Team
Forum Team
960 Views
Message 3 of 7
Flag for a moderator

Re: Elder Scrolls Online Disconnects

Hi red_blue,

 

Sorry to hear you're experiencing disconnects whilst playing Elder Scrolls.

 

Are you still experiencing issues since you last posted?

 

If so, are you experiencing the same issue in general or only during Elder Scrolls?

 

Have you always had this problem or is it a recent problem?

 

Thanks,

 

Lisa

0 Kudos
Reply
Highlighted
  • 4
  • 1
  • 0
Tuning in
954 Views
Message 4 of 7
Flag for a moderator

Re: Elder Scrolls Online Disconnects

Hi Lisa,

Thank you for your reply.

I am still experiencing issues. I only experience this in Elder Scrolls Online and I have always had this problem.

The issue is reliable in its occurance, for example at the end of dungeons, loading screens and then sometimes randomly.

At the moment I am dealing with it, but its very annoying as players have to wait for me. I'm 100% sure its nothing to do with my computers hardware.

- Intel i7-7700k 4.5GHz, 16GB RAM, GTX 1070, Installed a new HDD.

It seems that the game is unable to communicate correctly with my ISP (given exception is OS firewall).

 

Regards,

0 Kudos
Reply
Highlighted
  • 1.64K
  • 87
  • 155
Forum Team
Forum Team
952 Views
Message 5 of 7
Flag for a moderator

Re: Elder Scrolls Online Disconnects

I'll send you a Private Message so I  can take a look on our side.

 

Please reply back to my Private Message so I can take some details from you.

 

Thanks,

 

Lisa

 

0 Kudos
Reply
Highlighted
  • 3
  • 0
  • 0
Joining in
596 Views
Message 6 of 7
Flag for a moderator

Re: Elder Scrolls Online Disconnects

This frequently happens to me and whenever I phone up about it, I get fobbed off with excuses or the old, 'everything's working.' when clearly it isn't. 

0 Kudos
Reply
Highlighted
  • 4
  • 1
  • 0
Tuning in
585 Views
Message 7 of 7
Flag for a moderator
Helpful Answer

Re: Elder Scrolls Online Disconnects

I upgraded to the super hub 3.0 and it solved the problem.

Seems like there was a issue with the old hub 2ac firmware/hardware.
0 Kudos
Reply