cancel
Showing results for 
Search instead for 
Did you mean: 

Can’t connect to EA servers

Dojo1
Joining in

Hello,

I just recently purchased an xbox x and a few EA games. But it seems like I can’t connect to any of the EA servers.

Does anyone know why this keeps happening or how to fix this? I’ve already tried a few suggested solutions on forums and youtube but still no success.

It seems a lot of people who use virgin are all having the same issues as I am.

Any help would be much appreciated thanks!!

 

3 REPLIES 3

Alex_RM
Forum Team
Forum Team

Hi Dojo1,

Thanks for posting and welcome to our community 🙂

I'm sorry to hear you're having some issues connecting to EA servers.

I've had a look at things from our side and everything looks to be within the specifications we would expect.

Are you okay connecting to other sites?

Is the problem over a wired or wireless connection?

Alex_Rm

hey Alex!

Yeah everything is working fine.

I have the hub 3.0, around 100mbps of download speed over 20mbps of upload speed.

Working from home works fine, Netlix and Disney Plus is working fine, all other games are working fine.

It seems like it’s only the EA based games that aren’t working. More specifically the online servers for Battlefield 2042 and 4.

Is there anything I can modify or try to fix this? I’ve read a few suggestion on port forwarding changing DNS, but not sure what this means and how this could affect things I do.

do you maybe have any suggestions on anything I could try or change on the hun 3.0??

Hi Dojo1,

Thank you for reaching back out, sorry to see it is just the Xbox which is facing issues, have you checked the manufacturers website to see if anyone else faces the same issue and may have a possible fix?

Regards

Paul.