cancel
Showing results for 
Search instead for 
Did you mean: 

Buffer Bloat and Network jitter issue

rp18100
Tuning in
Some background info: 
 
I am getting lag spikes when playing Valorant (PC Game) - for some reason the average ping is relatively stable but there is a lot of network jitter (sometimes spiking up to 40-50ms). This has caused the game to be unplayable. I have tried resetting the router and QOS - but none of these seem to work. I use an ethernet cable which is connected to the router which is connected to the HUB (put in modem mode).
I don't understand the reason for this, I am not expecting extremely low ping but with an ethernet cable Id expect stable ping at least.
 
Are there any checks or potential fixes we could run on your end? I just want to make sure its not an ISP related issue and if so, try fix it!
 
Any suggestions would be appreciated.
 
Thank you
5 REPLIES 5

legacy1
Alessandro Volta

Buffer Bloat is to do with being rate limited by the hub with no QoS/BWM so you need to adjust your rate limits on your router so that you rate limit under rule of thumb -10Mb of your download speed and -1Mb of upload check here if done right.

https://www.waveform.com/tools/bufferbloat

but this only all works if the bandwidth is available such that if you limit 340Mb but get less speed your being limited likely VM side which might only do QoS/BWM per modem causing your packets to Buffer Bloat and its even worse for upstream.

You can run a BQM to check your jitter and spikes if its bad might not be much you can do and being down to many others in the area uploading causing you to spike and jitter

https://www.thinkbroadband.com/broadband/monitoring/quality

---------------------------------------------------------------

rp18100
Tuning in
https://www.thinkbroadband.com/broadband/monitoring/quality/share/faabd324691f1435a171831db5fcfc3c9d01f8db-13-05-2023

 

Thing is I have tried running QoS but it only seems to add intermittent packet loss and doesn't really fix the issue. I capped it at 70mbs download 5 mbs upload which is below my normal speeds.

Is there anything virgin media can do on their end? I've exhausted my options

Hey rp18100,

Welcome to the community and thanks for taking the time to post here on the forums.
I’m sorry to hear of the issues that you’re having with your connection at the moment, I have looked into this on our system and cannot see anything that would be causing the issues, how has your connection been running since you last posted?

Kind Regards,

Steven_L