Menu
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
162 Views
Message 1 of 3
Flag for a moderator

Broadband keeps dropping out or running at 10% of speed it should

Hi,

I am at my wits end with the broadband service I'm receiving just now. I am paying for 200Mbps but frequently only get 20-30!! I have the Hub 3.0. I've tried restarting and resetting to no avail.

There has a been a gradual decline in the reliability of the service for a few months but for the last 2-3 months it can be difficult for a teenager and one adult to both use ethernet and wifi devices at the same time. Now in lockdown, I have 3 young people with me who need to use the broadband for Uni work as well as entertainment. I am working from home and finding Video meetings are tortuous as they keep freezing (Skype, Zoom etc). Uni lectures are relying on these apps too so we are all getting very frustrated. I have tried messaging Virgin but get nothing back. I have also tried calling and am getting nowhere. I understand that some call centre are closed but am beginning to think that ALL of them are and that I am expected to keep paying through the nose for a substandard product with no hope of repair.

Please help!

0 Kudos
Reply
Highlighted
  • 83
  • 16
  • 23
Forum Team
Forum Team
110 Views
Message 2 of 3
Flag for a moderator

Re: Broadband keeps dropping out or running at 10% of speed it should

Hi,

I can take a look if you like. Send me your account number and area reference number via private message and I will get back to you.

Thanks

Lee


Here to help! I'm a technician helping out whilst working from home. Find out more


0 Kudos
Reply
Highlighted
  • 7
  • 0
  • 0
Joining in
87 Views
Message 3 of 3
Flag for a moderator

Re: Broadband keeps dropping out or running at 10% of speed it should

I've done yet another factory reset on the hub which seems to temporarily have done the trick but will keep monitoring it and seek more help if it deteriorates.
Thanks
0 Kudos
Reply