Showing results for 
Search instead for 
Did you mean: 

email login timed out - since May 2022

Joining in

I see one other person has complained of this and one suggested remedy of CtrlShiftR doesn't help me. I have made ample complaints about this, which began when VM updated the interface. I have changed nothing about my machines. I have tried elsewhere and I managed to login to webmail but, I noticed significantly, the first page of the process appeared there but not at home. At heart is the VM principle of putting marketing ahead of functionality. It worked best when it was html ONLY and has been degraded progressively with every update since. I use a client but that has less search facility than even the pseudo-outlook of VM.


Forum Team
Forum Team

Hi Trevor_Cave,

A warm welcome and thanks for posting on our community forums. We're sorry to hear that you have had to raise a complaint about our services. 

Can we ask exactly what your experiencing issues with? We will try to help as much as we possibly can.

Kind regards Jodi. 

Hello again Jodi,

Sorry I've been busy. I resume my discourse:

Beginning around the end of May last year, when Virgin started to change the VM web pages, there were times when my usual login process into email was disrupted. Sometimes almost all the page would appear but  flicker and be unusable.  Occasionally it would work for  day or so, then fail for weeks.

I would of course try calling 150 and sometimes the VM team in India could make it work but those in UK could not. Eventually UK could as well and even I could in London but not here.

I have not changed anything about my set up.  VM has changed around me and mine is among some others that can no longer reach email without a client.  They have called me twice when I was out and then stopped calling.

The most significant difference between what appears on my machines and not elsewhere is that the very first page of the interface, with the pull down menus along the top and a picture from a film upper left. This appears only elsewhere and then clicks on to the sequence of being asked about 4 times to sign in but it DOES NOT APPEAR at home. I am offered first the “2nd” page with a sign in button and they then follow through the same next four or so. The it just times out before it displays a full email interface.

It was FAR more useful when it was html ONLY but that couldn’t do the admin and marketing things that VM want but I don’t.

What more can you suggest please?






Hi @Trevor_Cave,

Thank you for expanding. To clarify, you're having issues accessing and using the webmail platform on our website using one or more of your devices, but when you use other devices you cannot replicate the issue?


Zach - Forum Team
New around here? To find out more about the Community Forums, take a look at our FAQs!