Showing results for 
Search instead for 
Did you mean: 

No Password message on iphone

Joining in

I cannot receive or send email on my iphone as it keeps telling me that I have not entered a password.

I have tried several times. Email on my ipad and via the My Virgin Media site are fine. I have had the same address for about 15 years and this is the first time it has happened. Does anybody know a way through it?


Forum Team
Forum Team

Hi Wizzardian, thanks for posting and welcome to our community.

Sory to hear you're unable to use your email on your iPhone.  Are you using the same email client as you do on your iPad?  Is your software up to date on the iPhone?  Also have you attempted to sign out and sign back in on your iPhone?



Hi Lee

Identical on iphone and ipad.

I have tried deleting account and then adding again, switching off and on etc.

Nothing works so far

Thanks for the response,

So just to clarify is this just regarding the Mail app on Apple devices?

Are you receiving any error messages or codes?

Also when was the last time you received an email on there?



The problem is just on my iPhone.

the message says “Cannot get mail”

No password provided for “Virginmedia”. But it is there in settings and I have reentered it several times.

Thanks for getting back to us Wizzardian

Have you recently updated your password and possibly not changed the password on one of your devices?  Also, have you tried deleting your cache on the app on your iPhone?