cancel
Showing results for 
Search instead for 
Did you mean: 

Incoming Emails to @ntlworld.com Addresses Blocked

robinwilson16
On our wavelength

Hello

I run an email server which is not blacklisted by anyone (mail.robindigital.co.uk @ [IP removed] ) yet emails sent to @ntlworld.com addresses are always blocked.

Emails to all other domains work without issue and the issue seems specific to @ntlworld.com

I have looked to see if there is a de-listing process but cannot find one.

Please can someone advise how this can be addressed.

Thanks

Robin

31 REPLIES 31

ravenstar68
Very Insightful Person
Very Insightful Person

Are you able to try sending me an email if I PM you my email address.  I want to see what happens when it hits my own email servers?

Tim

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Hi @RMTN, thanks for reaching out to us and a warm welcome to the Virgin Media Community Forums. 👋🏼

I'm sorry to hear about the issues with the emails you are experiencing.
May I ask if this is the same issue that occurs when you try sending an email from web mail or is this issue with web mail and / or client app?

Kind regards,
Ilyas.

Ilyas_Y
Forum Team

New around here? Check out the do's and don'ts, in our Community FAQs


ravenstar68
Very Insightful Person
Very Insightful Person

@Ilyas_Y for the avoidance of confusion, the OP is not a Virgin Media customer, he’s an external sender trying to send to an ntlworld.com address, although based on my knowledge, I also suspect if they check they will also see the same issue when sending to virginmedia.com blueyonder.co.uk and virgin.net addresses.

The error message that was unhelphully redacted indicates your mail exchangers rejected their servers HELO argument. Can you ask the mod team to put the error message back.

BTW the OP is @robinwilson16 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Thank you, Tim. I have emailed you to see if you can see the issue. Really appreciate your help with this and for noticing I am not a Virgin Media customer 😉

ravenstar68
Very Insightful Person
Very Insightful Person

It helps if you check the IP address presenting itself - (ipsrc in the error message from Virgin Media)

Your email server is announcing itself incorrectly.

When I checked my server log I saw the following received line

[REMOVED]

Bad HELO/EHLO configuration is one of the reasons email providers can choose to reject email.  I had enough trouble re-registering my own personal mail servers with Spamcop because because one of their servers was using an EHLO address that didn't resolve at all.

Tim

 

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

Hi Tim and thank you for getting to the bottom of this. That seems a bit strict on Virgin Media's part but will reach out to our hosting provider again to see if they can do anything. It is a shame there is no way of reaching out to Virgin Media support to request we are excluded from their spam filter.

ravenstar68
Very Insightful Person
Very Insightful Person

As a general rule companies don't like using whitelists as it opens up a possible path for spammers to use.

Good email practice states that a mail server should.

  1. Use it's fully qualified domain name (FQDN) in the HELO/EHLO
  2. That the FQDN should resolve to the IP address of the mail server.
  3. That the IP address that's connecting should have a PTR record that resolves back to the mail servers FQDN

Your reverse DNS is set correctly

The only thing that's wrong is the HELO,  Different providers do different things but I rather suspect that if you check emails to ziggo.nl addresses will be being bounced as well, not sure what other Liberty Global companies use the sane email system but I do know that it's unlikely to be just VM and Ziggo.

Tim

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

ravenstar68
Very Insightful Person
Very Insightful Person

@RMTN @Have you managed to speak to your hosting provider?

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

 


@ravenstar68 wrote:

@RMTN @Have you managed to speak to your hosting provider?


Thank you for the follow up. I did follow up with them and this was the response I received:

Since you are hosted on shared hosting server which is fully managed by Plesk control panel, we are all limited to what Plesk allows us to configure. Unfortunately, Plesk will always use ln15.myplesk.cc in EHLO, even when you are sending through your own dedicated IP address with FQDN, reverse DNS etc.

Apparently using a virtual server is the only workaround if we want our emails to make it through Virgin Media's spam filter, well, the only solution through our hosting provider anyway. We only have issues with @ntlworld.com and @virginmedia.com addresses so it doesn't impact a whole lot of our guests so will have to look at setting up a virtual server at a later date. It is strange as our emails got through just fine before, so this new issue just started recently so they must have tweaked their filters.

I just wanted to confirm in my case adding the reverse lookup record to resolve back to my server did work. I can see why Virgin add this restriction but I have not found anyone else to require a reverse lookup to match aside from Virgin. Not even Microsoft or Google are this restrictive.

I do also run shared hosting services so if another user started having issues sending to NTL World or Virgin Media email addresses it would be impossible to resolve it as the reverse IP address can only ever resolve back to one name (company1.com and not also company2.com).

The only workaround would then be to get a second line installed at home with a separate IP address and server linked to it. Or perhaps the same IP would work with different mail servers with their own SSL certificates and reverse lookup for each (mail-company1.company1.com and mail-company2.company2.com).

Either way this is excessive if I wanted to run an email system for 2 domains. I host services for around 30 but luckily for most as long as it is not blacklisted with Microsoft and Google then that is sufficient but this particular user was a higher volume user and due to having lots of staff, the expense of Office 365 account for everyone was too much.

It would be good if Virgin could consider relaxing this requirement in line with the mainstream email providers who use other ways to protect users from spam.