Menu
Reply
johnrambo18
  • 16
  • 0
  • 0
Tuning in
859 Views
Message 1 of 27
Flag for a moderator

Email sending

When using phone, emails can be received but not sent on 4g. It will work on wifi ok. Is this something in the settings?

Tags (2)
0 Kudos
Reply
coenoby
  • 2.15K
  • 300
  • 1.31K
Very Insightful Person
Very Insightful Person
839 Views
Message 2 of 27
Flag for a moderator

Re: Email sending


@johnrambo18 wrote:

When using phone, emails can be received but not sent on 4g. It will work on wifi ok. Is this something in the settings?


As far as I can recall the two most common causes for sending to fail when using mobile data but work fine on VM wifi are:

1) You need to have something in the subject line of the email. If it is left blank it will not send from a mobile network.

or

2) You need to have your full email address in the "username" field in the email app settings. So, "richardbranson@blueyonder.co.uk" will work ok from a mobile network but "richardbranson" will fail.

The reason is that VM apply tighter rules and validation on messages sent from non VM broadband (eg Mobile) networks than they do on messages originating from your home broadband network.

Worth checking out both of those to see if one applies in your case.😉

Coenoby

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
johnrambo18
  • 16
  • 0
  • 0
Tuning in
793 Views
Message 3 of 27
Flag for a moderator

Re: Email sending

thanks for the suggestions but I'm afraid it doesn't work.

I've checked the message has a subject and the sender Email is the full address.

It still will not send from 4G.  As soon as I connect to Wifi it is fine. I can receive messages but not send.

However I've checked Gmail and that will send and receive regardless of the method of connections.

Bizarely, the mobile network I am using is Virgin mobile!!

0 Kudos
Reply
HowardML
  • 12.33K
  • 1.44K
  • 41
Superuser Emeritus
Superuser Emeritus
787 Views
Message 4 of 27
Flag for a moderator

Re: Email sending

It is too early to say the solutions recommended don't work. You have apparently misconstrued the issue about the e-mail address. Of course the e-mail address is written out in full when you send an e-mail. But you need to check that in the app e-mail settings the entry for the username uses the e-mail address in full. Once you have confirmed this one way or the other we can advise further. 



I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

coenoby
  • 2.15K
  • 300
  • 1.31K
Very Insightful Person
Very Insightful Person
773 Views
Message 5 of 27
Flag for a moderator

Re: Email sending


@johnrambo18 wrote:

the sender Email is the full address


Thanks to HowardML for clarifying that for you, however I did say in my post "You need to have your full email address in the "username" field in the email app settings".

Coenoby

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

0 Kudos
Reply
johnrambo18
  • 16
  • 0
  • 0
Tuning in
750 Views
Message 6 of 27
Flag for a moderator

Re: Email sending

Please clarify what is meant by "username". Which field are we talking about?

0 Kudos
Reply
johnrambo18
  • 16
  • 0
  • 0
Tuning in
744 Views
Message 7 of 27
Flag for a moderator

Re: Email sending

Also just done another experiment. It will send from a different wifi network - in this case The Cloud in local Wetherspoon, so what was said about VM security concerns does not really ring true. Surely 4g is more secure than a public wifi?

0 Kudos
Reply
ravenstar68
  • 19.39K
  • 1.14K
  • 8.45K
Very Insightful Person
Very Insightful Person
738 Views
Message 8 of 27
Flag for a moderator
Helpful Answer

Re: Email sending

VM do have a number of security measures in place that might cause the issue.

The one I suspect is that the 4G IPv4 address is listed on Spamhaus' CSS meaning that the authentication attempt is rejected with a VM305 error

When connected to 4G find your public IP address by going to https://whatismyipaddress.com/

Once you have your IP address go here:

https://www.spamhaus.org/lookup/ and enter it.

Let us know what you find.

Note that when on 4G you don't have your own public IPv4 address.  You actually share it with others via CGNAT

Tim

I'm a Very Insightful Person, I'm here to share knowledge, I don't work for Virgin Media. Learn more

Have I helped? Click Mark as Helpful Answer or use Kudos to say thanks

johnrambo18
  • 16
  • 0
  • 0
Tuning in
706 Views
Message 9 of 27
Flag for a moderator

Re: Email sending

Have checked I.P. address links suggested. It comes as

Not in SBL

In CSS

in PBL

not in XBL

0 Kudos
Reply
johnrambo18
  • 16
  • 0
  • 0
Tuning in
690 Views
Message 10 of 27
Flag for a moderator

Re: Email sending

I have checked the phone for malware and it comes up clear. Also the Spamhaus site lists "heavily monetized or unofficial apps" as being guilty - I do not have any of these.

0 Kudos
Reply