Showing results for 
Search instead for 
Did you mean: 

Blueyonder emails cannot be sent - password invalid

Tuning in


I have an old blueyonder email address that up until tonight was working fine.

Despite my SMTP setting being set as advised on previous guidance, I am now being advised that my original password for my blue yonder emails in not valid.  It is correct and I have not changed it, however it will now longer accept it.  

Please help!


Hi, thanks for the feedback.  I tried logging in to my blue yonder emails using the link you provided.  It still shows as though the password is incorrect using that link so I don't think that its an issue associated with the app on my phone.

I have definitely not changed the original password from set up.. but it still advises that the password is incorrect.  This is exactly the same issue my sister had with her virgin email account that I manage on her behalf.  And that stopped working over a year ago advising that the password is incorrect when in fact again it has not even changed.

Any thoughts or help will be greatly appreciated!!,



Also, I should add that before I posted this query on the site, I did delete the account and added it again, this has happened once before and I did this and it fixed it but sadly at this time it has not resolved the error.



Hi @Lolu17 thanks a lot for your confirmation. 

It's unclear if you have tried this already, but does resetting your password resolve the issue, or will it not enable you to do so due to the error you're receiving?

If it does, please try doing this and let me know how you get on and we can take things from there.

Many thanks


Hi, thanks for your response, no it does not allow me to rest my password.



Hi @Lolu17 thanks for your reply and sincere apologies for this.

Please allow me to send you a PM so I can look into this further for you.

Kindly expect this to arrive shortly and respond directly when you can!
Many thanks


Thanks PM'd you direct