Menu
Reply
  • 12
  • 0
  • 1
jpf198
Tuning in
108 Views
Message 1 of 1
Flag for a moderator

Possible local network Bug with newest Tivo Box

We have recently had to swap out our much loved Tivo box for a new one due to a tuner fault with the original one, and thought I would just drop a note with the issue I have found and solved myself.

 

We have run the TV Anywhere App since release and Network Remote ever since we had the original one and wanted to with the new one. However doing a straight swap the new Tivo box would not get an IP address from the Virgin media router (r38 firmware) and after much resetting and faffing around I eventually got it to work on a fixed IP address.

 

I then recently had to move the kit around and when turning back on the Tivo could not be contacted on its fixed ip: from app or Ping: all activity lights were on the network and the onbaord network test passed:

 

Long story short i discovered that the box cannot properly auto negotiate its Ethernet speed and duplex settings with any of the Gigabit switches that I have, including the Virgin Media Router: the switches pick-up the fact it is 100 meg but cant then handshake properly: if you set manually on a managed Gigibit switch to 100 meg half or full duplex (or 10 meg even) then it is fine, gets ip and works without issue, but not on Auto it just wont work: Tried the VM Router, Netgear 1Gig router, netgear unmanaged gig switch, EtherGreen unmanaged gig switch then Cisco Managed gig switch:

 

It works fine auto negotiating on a 100meg unmanaged switch: and that is the work around i have put in by putting a spare 100meg switch behind the tv stack.

 

hope this information will help someone.

 

J

0 Kudos