Menu
Reply
  • 1
  • 0
  • 0
purplesu
Joining in
354 Views
Message 1 of 3
Flag for a moderator

My TiVo box making clicking sound

My TiVo box constantly making a clicking sound when switched on this morning,, says starting up but nothing happening,, switched off for 10 mins at back then on again,, still clicking and no service.

 

 The lights at front are going on and off in sequence,, clicking stops then starts again,, sounds like it's trying to connect but can't 

 

HD box upstairs is fine 

0 Kudos
  • 730
  • 44
  • 94
ilike2burnthing
Rising star
340 Views
Message 2 of 3
Flag for a moderator

Re: My TiVo box making clicking sound

Probably a hardware issue. You can wait here for a few days for an admin to pick it up or call 150 from a Virgin phone or 0345 454 1111 from any other phone.
0 Kudos
  • 6.85K
  • 217
  • 511
Forum Team
Forum Team
313 Views
Message 3 of 3
Flag for a moderator

Re: My TiVo box making clicking sound

Hi purplesu,

 

Welcome to the Community and thanks for posting on the Forum. I'm sorry to hear that your TiVo® is making a lot of noise and not loading up the channels.

 

I've tried to look into this for you now, but the remote testing I have initiated shows that the TiVo is offline. Please confirm if the box is powered on. If you normally leave the TiVo off, could you power it on in the morning and let me know? I can run testing after 8:30AM.

 

Looking forward to hearing back from you so we can get this sorted out for you.


Need help changing SIM card? Find out more about activating your 4G ready SIM. 4G SIM Swap Help


0 Kudos