Ask a question
Reply
Forum Manager (Retired)
Mark_Wilkin
Posts: 3,634
Registered: ‎04-08-2009

Re: R36 Upgrade Breaks VOIP

[ Edited ]

Sorry for taking a while to reply to this, I've flagged this up to the firmware team and they're investigating.

 

I've also checked back through the beta test forum for R36 and I can only find one specific report about someone having an issue with SIP and this user said that they managed to solve this issue by turning off uPNP in the Super Hub. If you're seeing this issue could you try that and report back on if it helps or not?

 

Thanks

Please use plain text.
Crafty
DerekCitsl
Posts: 24
Registered: ‎31-07-2012

Re: R36 Upgrade Breaks VOIP

OK thanks, I will try that later tonight - my VOIP phone is currently running on my backup BT ADSL line for work so I can't test anything during the working day in case I miss calls.

Please use plain text.
Boffin
martileic
Posts: 435
Registered: ‎13-04-2012

Re: R36 Upgrade Breaks VOIP

Turning off UPnP makes no difference, the problem is still there, if I set my registration back to default

Please use plain text.
Clever-clogs
thecremlin
Posts: 82
Registered: ‎16-02-2011

Re: R36 Upgrade Breaks VOIP

Not VOIP related.  But since R36 I've been having exactly the same issue with my own (normal) router plugged into the SuperHub (in modem mode).  Pre R36 it was fine, post R36 every 60minutes the router loses connection and needs restarting.  For the time being I've taken it out of the chain and put the SuperHub back into router mode.  Not quite the same issue, but similar symptoms.

Please use plain text.
One to Watch
WattoGold
Posts: 5
Registered: ‎06-08-2012

Re: R36 Upgrade Breaks VOIP FIX

An 08:00 call to the support desk answered by a top techie named billed found the answer inconjunction wiTh BT support on another phone simultaneously named Ian. 

 

 

The solution is to forward port 5060 to the Falcon phone ip address under the UDP setting....

 

I now have calls arriving at the handset once again.

 

It's great when you get three heads together that end in a positive result.

 

Thanks to those that contributed with their thoughts. I hope this works for anyone out there with he same issue.

You get to port forwarding under the advanced settings , range is 5060 to 5060 UDP protocolNAND you find the IP ADDRESS of the falcon phone By holding the menu button for a few seconds.

Please use plain text.
Crafty
DerekCitsl
Posts: 24
Registered: ‎31-07-2012

Re: R36 Upgrade Breaks VOIP FIX

OK thank you - I have just set that up and will post here how it goes - I have an hour before calls start coming in at 9am so it should be proven by then.

 

Thanks again - all credit to you for getting BT and VM techies on a conference call (WOW!) - it will be marvellous if it works!

Please use plain text.
Crafty
DerekCitsl
Posts: 24
Registered: ‎31-07-2012

Re: R36 Upgrade Breaks VOIP FIX

For anyone not familiar with routers, it's worth mentioning that you will need to fix the IP address of your phone in the DHCP settings, otherwise its IP address will change on reboot and the forwarding will break.
Please use plain text.
Crafty
DerekCitsl
Posts: 24
Registered: ‎31-07-2012

Re: R36 Upgrade Breaks VOIP FIX

OK that's over 2 hours and my BT Falcon still rings on incoming calls, so I guess we have a fix!

 

For reference, my uPNP is enabled and always has been, so I'm guessing that the Falcon phone may normally have done the port forwarding using uPNP.

 

R36 then, is causing the router to lose the port forwarding that is initially set up by the phone via uPNP after a few minutes. Forcing the port forwarding permanently fixes the problem.

 

So let's make it clear for everyone who is not familiar with routers.

 

1. Log in to your SuperHub

2. Go to Advanced / DHCP / DHCP Reservation.

3. Add Reservation:

Device Name = PHONE

MAC Address = (press and hold the Menu button on your phone to get it)

IP Address = 192.168.0.5 (any number on the end will do as long as it's not zero)

Apply.

 

4. Still in Advanced - Security / Port Forwarding: Add Rule:

Name=PHONE

Start Port = 5060

End Port = 5060

Protocol = UDP

IP Address = 192.168.0.5 (or whatever number you gave it in DHCP)

Apply.

5. Reboot everything.

 

Many many thanks WattoGold, I can finally stop falling over BT cables that were trailing all round the house from the backup ADSL!

 

Until VM release R37 of course..... :smileymad:

 

Please use plain text.
Forum Manager (Retired)
Mark_Wilkin
Posts: 3,634
Registered: ‎04-08-2009

Re: R36 Upgrade Breaks VOIP FIX

Glad to hear that's worked out for you, I've marked that last answer as a 'Helpful Answer' so it should show up at the top of any search results on this topic. Will also make sure the firmware team and our front line agents are aware.

 

Thanks

Please use plain text.
Boffin
martileic
Posts: 435
Registered: ‎13-04-2012

Re: R36 Upgrade Breaks VOIP FIX

This dosent work for me, the only way I can get around the problem still is to lower registration time, which is fine but the cause of the problem in the firmware needs to be found and fixed.

 

These are just work arounds to the problem, not a cure.

Please use plain text.