Menu
Reply
On our wavelength
  • 29
  • 0
  • 51
Registered: ‎02-12-2016
Message 1 of 619 (9,690 Views)

Hub 3 / Compal CH7465-LG (TG2492LG) and CGNV4 Latency Cause

[ Edited ]

Good Day Ladies and Gentlemen,

Greetings from the other side of the pond, so to speak.  Over the last few weeks I've been perusing various user forums across North America and Europe for issues related to Intel Puma 6 modem latency.  Of those forums, your Hub 3 stands out as yet another Puma 6 based modem where users see continuous latency no matter what site is used or what online game is played. Considering all of the problems that are on the go, the following information should be of interest to all Hub 3, Compal CH7465-LG and Hitron CGNV4 modem users.  There is much more to post regarding this, so this is a start, to alert VM users as to the real cause of the latency and hopefully engage the VM engineering staff, via the forum staff, with Arris.  I am surprised to see that there has been no mention on this board of users from other ISPs who are suffering the exact same issues with their modems, so, this may come as a surprise to some, and possibly old news to others.

So, the short story ........

The Hub 3 / Compal CH7465-LG (TG2492LG) & Hiton CGNV4 modems are Intel Puma 6 / 6 Media Gateway (MG) based modems.  These modems exhibit high latency to the modem and high latency thru the modem.  The latency affects all IPV4 and IPV6 protocols, so it will be seen on every internet application and game.  The basic cause is the processing of the data packets thru a CPU software based process instead of thru the hardware processor / accelerator.  It appears that a higher priority task runs periodically, causing the packet processing to halt, and then resume.  This is observed as latency in applications and in ping tests to the modem and beyond.  For the last several weeks, Hitron, along with Intel and Rogers Communications in Canada have been addressing the latency issue within the Hitron CGNxxx series modems.  To date, only the IPV4 ICMP latency has been resolved.  Although this is only one protocol, it does show that a Puma 6MG modem is capable of using the hardware processor / accelerator with good results.  Currently Rogers is waiting for further firmware updates from Hitron which should include an expanded list of resolved protocol latency issues.  For Arris modems, "Netdog" an Arris engineer indicated last week that Arris was onboard to address the issue for the Arris SB6190 modem.  That should be considered as good news for any Arris modem (read Hub 3) user as Arris should be able to port those changes over to other Puma 6/6MG modems fairly quickly.  This is not a trivial exercise and will probably take several weeks to accomplish.  Note that there is no guarantee at this point that it is possible to shift all packet processing to the hardware processor / accelerator without suffering from any packet loss side effects.  Time will tell if all of the technical issues can be resolved with the current hardware included in the Puma 6/6MG chipset.  Last night, Netdog loaded beta firmware on selected test modems on the Comcast Communications network.  As this was only done last night, it's too soon to tell what this version resolves and if it was successful or not.  Netdog has contacts with staff at Comcast, Rogers, Charter and Cox Communications to fan out beta versions and modifications for testing.  I'd say its time to add Virgin Media and/or Liberty Global to that group as well.

Recent activity:

Approx three weeks ago a DSLReports user, xymox1 started a thread where he reported high latency to an Arris SB6190 and illustrated that with numerous MultiPing plots.  This is the same latency that I and other users with Rogers communications have been dealing with for months so it came as no surprise.  As well as reporting via that thread, xymox1 took it upon himself to email several staff members at Arris, Intel, Cablelabs and others.  The result of that campaign was Netdog's announcement, last week, that Arris was fully engaged at resolving the issue.  That has led to last nights release of beta firmware, although as I indicated its too early to determine what the beta firmware resolves, if anything.


The original thread that xymox1 started is here:

https://www.dslreports.com/forum/r31079834-ALL-SB6190-is-a-terrible-modem-Intel-Puma-6-MaxLinear-mis...


Yesterday, DSLReports issued a news story covering the thread:

https://www.dslreports.com/shownews/The-Arris-SB6190-Modem-Puma-6-Chipset-Have-Some-Major-Issues-138...


Today, Arris responded:

https://www.dslreports.com/shownews/Arris-Tells-us-Its-Working-With-Intel-on-SB6190-Puma6-Problems-1...


That response was also picked by Multichannel.com

http://www.multichannel.com/news/distribution/intel-arris-working-firmware-fix-sb6190-modem/409379

This is more news likely to appear in the next few days as additional tech and news staff pick up on this issue.


Hub 3 observations:

Like many others using a Puma 6/6MG modem, Hub 3 users are experiencing latency when they ping the modem, or ping a target outside of the home, game online or use low latency applications.  The common misconception is that this is Buffer Bloat. It's not. Its most likely a case of the packet processing stopping while the CPU processes a higher priority task.  The packet processing is done via the CPU no matter what mode the modem is operating in, modem mode or router mode and no matter what IPV4 or IPV6 protocol is used.  Normally, the latency is just that, latency.  The exception are UDP packets. In this case there is latency and packet loss.  The result of that is delayed and failed DNS lookups, and poor game performance for games that use UDP for player/server comms or player/player comms.


Can this be fixed?

So far, it appears that the answer is yes.  Rogers Communications issued beta firmware to a small group of test modems in October.  This version shifted the IPV4 ICMP processing from the CPU to the hardware processor / accelerator, resulting in greatly improved performance in ping latency.  At the present time we are waiting for the next version firmware which should shift other protocols over to the hardware processor / accelerator.  That can be seen in the following post:

http://communityforums.rogers.com/t5/forums/forumtopicpage/board-id/Getting_connected/message-id/369...

The details and results of last nights beta release to the Comcast group have yet to be seen.

At this point there is enough reading to keep most staff and users busy.  My intention is to post some of the history leading up to this point and instructions on how to detect the latency and packet loss.  This is not thru the use of a BQM.  I had hoped to post this all at once but events are moving much faster than I had thought they would.  For now this should suffice to get the ball rolling.

Below is a link to a post with a couple of HrPing plots from my 32 channel modem to the connected CMTS.  This shows the latency that is observed and reflects what others have posted in this forum using Pingplotter and HrPing.

https://www.dslreports.com/forum/r31106550-

HrPing is one of the freebie applications that can be used to monitor the latency to and thru the modem. 

Pingplots with Pingplotter which show the latency from my modem to the CMTS can be found in the first two to three rows of my online image library at Rogers Communications, located below.  They are essentially what the BQM would look like if you were able to zoom into the plot to the point where you could see the individual ping spikes.  Those ping spikes are common to Puma 6 and Puma 6MG modems.

http://communityforums.rogers.com/t5/media/gallerypage/user-id/829158

 

 

 [MOD EDIT: Subject heading changed to assist community]

Hero
  • 9.15K
  • 286
  • 786
Registered: ‎29-01-2011
Message 2 of 619 (9,655 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

They all know that they can do hardware processor / accelerator for modem mode as a fix along with disabling processor power saving.

Up to speed
  • 115
  • 1
  • 32
Registered: ‎23-03-2016
Message 3 of 619 (9,643 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

This is really interesting reading and gives some hope for us hub3 users. Thanks for the post and please keep the thread updated with any further news Smiley Happy
Superfast
  • 129
  • 2
  • 28
Registered: ‎08-03-2014
Message 4 of 619 (9,636 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

finally, smoking gun confirmed! 

--I'm just another virgin user like you. Please mark my answer as helpful, if it helped Smiley Happy
On our wavelength
  • 22
  • 0
  • 6
Registered: ‎25-03-2016
Message 5 of 619 (9,589 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

Great post.

Superuser
  • 8.66K
  • 319
  • 2.1K
Registered: ‎30-01-2013
Message 6 of 619 (9,554 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

[ Edited ]

Thanks for the update @Datalink.

This isn't exactly news to me..

Yes, we'd reported a latency issue back in September 2015 during the first few days of the SuperUser trial of the Hub 3 (TG2492LG-VM) and February 2016 during the trial of the Hitron CGNv4. It has since been reported continually on the main forum by users of both hubs.

I posted back in October 2015 that the CPU used in the Hub 3 was the Puma 6/6MG SoC (most likely DHCE 2652) and started researching other modems that use the same Intel SoC family. Like you, I found similar issues on Comcast and other cable forums in Europe and the USA with users using Puma 6/6MG modems.

Unfortunately the Comcast forum is closed, so I couldn't post there and ask further questions. Similar issues with user registration for Cox and other USA based cable forums. Sorry I couldn't tell you guys what I found and give you a heads up.

Nice to see you got some traction with Intel and Arris at last. VM has been totally unresponsive about any latency issue. They don't give any info in the trials of substance.

 

On our wavelength
  • 29
  • 0
  • 51
Registered: ‎02-12-2016
Message 7 of 619 (9,534 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

Hi, yes its very unfortunate that you reported the latency issue and yet it appears to have gone nowhere, leaving Puma 6 users in the UK struggling with this today and well into the future.  There is a huge cost to any ISP that isn't taking this seriously.  Every time a technician / engineer is dispatched to resolve the latency problem within the modem, which he or she can't solve, that costs money.  So there's a bottom line cost issue.  It also costs time, time spent where that individual could be attending to another customer that has real issues with cabling and signal issues. And at the end of the day, it drives customers away out of frustration.   Very unfortunate indeed.  Having a receptive engineering group within your ISP is a tremendous help in this situation. 

Here's a suggestion as you indicated that Comcast had closed their own forum.  Keep an eye on the DSLReports forum to see what comes up.  Keep watching for Puma 6 or SB6190 issues in the U.S. ISPs Cable:  Cox and Comcast XFinity forums and in the Hardware By Brand:  Arris/Surfboard forum.  Don't hesitate to chime in during any of the discussions these days as it will reinforce the point that this is a multi-modem, multi-ISP issue on both sides of the Atlantic.  Hopefully, further evidence of other Puma 6 modems with the same issue will keep the pressure up to see that this if finally resolved.  I'd love to see a European section within the DSLReports forums.  That would have made some of this research much easier and provided a conduit to chat about issues such as this.

https://www.dslreports.com/forums/4

https://www.dslreports.com/forum/r31079834-ALL-SB6190-is-a-terrible-modem-Intel-Puma-6-MaxLinear-mis...

https://www.dslreports.com/forum/r30771922-Firmware-Problems-with-the-new-6190-firmware-9-1-93N

https://www.dslreports.com/forums/18

https://www.dslreports.com/forum/r30339360-Arris-SB6190-32x8-cable-modem

 

Up to speed
  • 115
  • 1
  • 32
Registered: ‎23-03-2016
Message 8 of 619 (9,493 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

Superuser
  • 11.65K
  • 1.53K
  • 3.33K
Registered: ‎22-06-2013
Message 9 of 619 (9,385 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

[ Edited ]

@Datalink Excellent post and info. This issue has annoyed me greatly since I noticed it during trialing this hub, more so than the UI bugs. Despite repeatedly trying to get Virgin Media to take it seriously through various channels, all my prompting fell on deaf ears. 

Edit: Typo fix

- - - - - -
Any opinions expressed by myself are my own and do not represent Virgin Media in any way.
Reply
0 Kudos
Superfast
  • 1.1K
  • 4
  • 24
Registered: ‎14-09-2012
Message 10 of 619 (9,339 Views)

Re: Hub 3 / Compal CH7465-LG (TG2492LG) & CGNV4 Latency Cause

Just seen this on the register website, a firmware update is due it says

Reply
0 Kudos