Menu
Reply
  • 1
  • 0
  • 0
MADsMoKe
Joining in
128 Views
Message 1 of 2
Flag for a moderator

Completely un-usable High Ping/ Low Speed

So to make this clear, i've been a customer since August 2015 When i signed up i made sure that Virgin promised i would receive as close to the speed as promised. 

I was not advised of any fault with broadband in my area at time of purchase. 

Now for a whole year i have never received anywhere close to speeds promised. I have made several phone calls to the technical team and they have always advised me that there is a fault with broadband in the area and it will be repaired (insert date one month ahead of this date) this has been happening for a year! 

Now i called on monday, again!... Sigh yet again told it will be another month October 26th 

Fault Ref: F003770024 

Fault begin date: 5th July 2015 (Before i joined) surely i should have been advised of fault with Broadband in the area!

Anyway now i have started my Education through open university i struggle to load websites and this is causing a strain in my education as i need the internet to complete my course work. I have come to the end of my tether.  

0 Kudos
Reply
  • 10.46K
  • 290
  • 616
Forum Team
Forum Team
68 Views
Message 2 of 2
Flag for a moderator

Re: Completely un-usable High Ping/ Low Speed

Hi MADsMoKe

 

Thanks for posting and a warm welcome to the community.

 

I'm sorry to read that you are experiencing issues with your broadband connection due to a fault in your area.

 

I would like to check this in more detail, however I was unable to locate your account. I've sent you a PM (purple envelope icon, right corner) requesting some details. Once you have replied I can look further into this.

 

Hope to hear from you soon

Sam


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply