Joining in
  • 1
  • 0
  • 0
Registered: ‎15-12-2010
Message 1 of 2 (715 Views) - device cannot start



I am getting intermittent problems trying to connect to the Internet on my desktop pc which is wired into the router, I have tried switching off and on the router without success. My laptop which connects wirelessly does not experience the same problems. I noticed within device manager I am seeing a yellow warning triangle against the above network adaptor. The properties shows the device status as "this device cannot start (Code 10) ", I clicked "check for solutions" and had the message "could not load driver software". The other network adapter listed is an Atheros L1 Gigabit Ethernet, status ok. I have seen references to problems with Atheros adapters and the I am not very technically minded but if anyone can offer assistance it would be greatly appreciated.


many thanks

0 Kudos
Forum Team (Retired)
  • 3.39K
  • 69
  • 184
Registered: ‎18-03-2010
Message 2 of 2 (689 Views)

Re: - device cannot start

Hi gellebr,


The issue with Atheros adapters is generally with wireless networks: wired connections should not be affected.

From the issue that you've described, it sounds as if the driver software for the network card in your PC is faulty or out of date. I'd recommend that you visit the network card's manufacturer's website, and download updated driver software for the device.

Please let us know how you get on.


David Owen
Help & Support Forum Team

If someone's helped you out say thanks by clicking on the Kudos Star. If someone's solved your problem, why not mark their message as a Helpful Answer? You can also help other users find useful posts by Tagging them with keywords.

If you are new to the forum, please remember to search the forum before posting your question. Please don't send private messages directly to the forum team unless they ask you to, post your issue to the forum first.
0 Kudos