Joining in
  • 2
  • 0
  • 0
Registered: ‎28-04-2010
Message 1 of 3 (5,321 Views)

Freedom VM F10 will not cold boot

Hi All, I am new to this forum, and I guess like many, you only look to join when you have a problem..!!




OK, to my problem. On a cold boot (so from PC being completely powered down) I get a BSOD. The error on the BSOD shows 0x00000050 with ntfs.sys as the likely culprit. But on a restart after this error things boot up fine. If you let the OS reboot itself it will just loop between this error and restarting, over and over. But, if you manually power off (by holding the power button), then power back on it will restart fine.


I have tried rebooting using PC Angel several times (issue not solved), I have exchanged the hard drive and the RAM and loaded a whole new version of Windows XP Home (using the same key as provided with the PC)....still the same problem.


The laptop is only a few months old and boy is this frustrating and completely lowers my thought of VM !!!


So I have a few questions.


1. I have reformatted the original hard drive manually....I can still see the PC Angel partition and have left that intact, although I am not currently given any option to boot from there a way I can boot from PC Angel to restore everything back to factory settings ? I have tried with options on F12, F2 to check BIOS boot order & F10 doesn't do anything. Or can I download an image to copy onto the original HD or run a .exe ?

2. Any idea's why I cannot cold boot ?

3. Can I create a USB boot option ?


Any advise greatly appreciated. I am currently paying £15 a month for a dongle I get very intermittent signal with and a laptop that doesn't even work and doesn't seem to be well supported by VM.


Thanks in advance.




0 Kudos
Trouble shooter
  • 2.81K
  • 140
  • 668
Registered: ‎09-09-2009
Message 2 of 3 (5,311 Views)

Re: Freedom VM F10 will not cold boot

The usual cause for this error is faulty RAM. Unlikely in your case as you have already exchanged your memory.


Try reinstalling your graphics drivers.


You may have a corrupted NTFS volume which can also generate this error. Run Chkdsk /f /r to detect and repair disk errors. You must restart the system before the disk scan begins on a system partition. If you cannot start the system due to the error use the Recovery Console and run Chkdsk /r .


Drivers for the Freedom Netbook are available here:- edia-freedom-device-drivers/ which (apparently) includes 


  • Audio
  • Chipset
  • EventService
  • Graphics
  • LAN
  • Touchpad, and
  • Wireless

Large file, approx. 64 megabytes ( I have no personal knowledge as to the comaptability of these drivers, Use of these are at your own risk.)


Formatting your original HDD mave have removed the ability to do a restore from PC Angel ,you may have got rid of the software that allows recovery from the hidden rescue system partition.


Searching the web has provided a possible solution to that:-


1. Download EasyBCD and Install it from
2. Run it and go to the Add/Remove Entries Screen
3. Click on the Linux tab at the bottom
4. From the drop down list select the partition ????

5. Tick 'GRUB isn't installed to the bootsector'
6. Click 'Add Entry'
7. Go to the NeoGrub tab and click 'Remove NeoGrub'

8. Go back to the Linux tab and deselect 'GRUB isn't installed to the bootsector'
9. In the name box, enter something like 'Recovery' and ensure the drop down list still has partition ???? selected

10. Click 'Add Entry' and click save at the top

11. Restart the netbook and select the new Recovery option from the boot menu to inititialise recovery

(Courtesey of Ben_B, posting on here:-


Good Luck!

0 Kudos
Joining in
  • 2
  • 0
  • 0
Registered: ‎28-04-2010
Message 3 of 3 (5,290 Views)

Re: Freedom VM F10 will not cold boot

Hi Sololobo, thanks for the response.


I am currently  running the checkdisk so hopefully that can detect any issues with the file system. In previous installs I have tried using the drivers you suggest, I have even tried going direct to the chipset manufacturers site & tried their drivers.


Anyway, just wanted to say thanks and I will heed your advise, then post back here the results.



0 Kudos