Showing results for 
Search instead for 
Did you mean: 

Account problems

Joining in

I tried to create an account with Virgin Media so I could log into the app and control some Virgin Media WiFi pods. However when I tried to create the account it failed at the verification step. Either one of two things would happen:

  • I would wait for a long time for the verification email to be sent, and once I had received it the verification link had expired. I would try to get it sent again when this happened.
  • Sometimes when I click the link in the email it loads a page that just states "Complete your profile". There isn't anything on this page for me to do or click so I can't do anything. I also can't resend the verification link.

I am now unable to:

  • access this new account
  • resend a verification link

Alessandro Volta

VM pods only work with a VM Hub. 

A VM Hub only works with a VM broadband service. 

A VM broadband service only works with a VM account. 

So if you don't already have a VM account they aren't going to work. 

- jpeg1
My name is NOT Alessandro. That's just a tag Virginmedia sticks on some contributors. Please ignore it.

Forum Team
Forum Team

Hi Tco07,

Thank you for your post. I'm very sorry to hear about the issue with registering an online account.

To confirm, do you have services with ourselves?


Yes I do have. I'm with virgin since 2022 December, always paying my bills through the phone call, but now contract coming to the end, and can't change anything, because can't login/verify online account 

Thank you for confirming this @Tco07 

What happens if you just try and log in now here with the details you entered?

I've seen it before where the error that the link has expired is wrong and the verification has gone through. 

Let us know what the page flags at your side when you try signing in and we'll assist further if needed. 

Here to help 🙂
Virgin Media Forums Agent