Menu
Reply
  • 3
  • 0
  • 1
torin
Tuning in
374 Views
Message 1 of 9
Flag for a moderator

Phone won't ring since install

Since installation of my Virgin line 20 days ago my phone has not worked, that the ringer won't ring when someone calls it.

I have rung the support number so many times and it is still not fixed. Excuses every time and I'm either told to wait 48 hours, there's a fault on my line it's being fixed, or reboot my router, or it's my equipment fault.

Searching the forum my problem is similar to this:

https://community.virginmedia.com/t5/QuickStart-set-up-and/House-phone-not-ringing-in/m-p/3898966#M1...

So possibly I need the 'black' phone adaptor with the capacitor.

How do I get one?

  • 10.3K
  • 642
  • 1.36K
jb66
Alessandro Volta
365 Views
Message 2 of 9
Flag for a moderator

Re: Phone won't ring since install

Do you have an old phone?
0 Kudos
Reply
  • 3
  • 0
  • 1
torin
Tuning in
360 Views
Message 3 of 9
Flag for a moderator

Re: Phone won't ring since install

Well, I bought it a year or so ago.

But I guess it's a traditional BT socket phone. I can't use the docking station ones owing to hearing issue.

0 Kudos
Reply
  • 1.08K
  • 63
  • 74
Forum Team
Forum Team
339 Views
Message 4 of 9
Flag for a moderator

Re: Phone won't ring since install

Hi torin, 

 

Thanks for your post and welcome to our community Smiley Happy

 

Sorry you're experiencing some issues with the line.

 

Can you confirm if you've been able to test a different handset and whether you're able to make outgoing calls?

 

Kind regards, 

 

Alex_Rm

0 Kudos
Reply
  • 3
  • 0
  • 1
torin
Tuning in
306 Views
Message 5 of 9
Flag for a moderator

Re: Phone won't ring since install

Thanks,

After much frustration with support I've finally had an engineer out.

Solutions seemed to be to use an old ADSL filer plugged into the Virgin filter which had the capacitor. The Virgin engineer was using the same phone to test lines as I was using and it was his solution.

 

0 Kudos
Reply
  • 1.22K
  • 68
  • 118
Forum Team
Forum Team
297 Views
Message 6 of 9
Flag for a moderator

Re: Phone won't ring since install

Cheers so much for popping back with an update @torin Glad that things have been sorted out. 

 

Hope you have a good weekend - you know where we are if you need any help Smiley Happy 

 

Cheers

Katie - Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 4.2K
  • 280
  • 704
Roger_Gooner
Community elder
292 Views
Message 7 of 9
Flag for a moderator

Re: Phone won't ring since install

This keeps coming up and nobody in VM addresses it. Some old handsets require a ring capacitor and a solution is to replace the VM-supplied RJ11 to BT adapter with one that does have this capacitor, costs £4 off eBay. How hard is it to update documentation or scripts.

--
Hub 3.0, TP-Link Archer C8, TP-Link TL-SG1008D 8-port gigabit switch, V6
My Broadband Ping - Roger's VM Broadband Connection
0 Kudos
Reply
  • 10
  • 0
  • 0
Jussy1974
Joining in
268 Views
Message 8 of 9
Flag for a moderator

Re: Phone won't ring since install

Our landline didn’t work for nine months and showed faulty on service status.

Its dreadful. I took the double adapter out, try it.

0 Kudos
Reply
  • 10
  • 0
  • 0
Jussy1974
Joining in
266 Views
Message 9 of 9
Flag for a moderator

Re: Phone won't ring since install

Virgin is a dreadful service.

Its not fibre  at all but coax cable to your house.

The phone goes down the cable and the tv and not the original line.

It’s a reason why broadband is slow. 

What they don’t tell you is the equipment is used to make your house a virgin hot spot using your box.

The site is always down, you can upgrade via online chat etc but can’t downgrade or complain or end service without calling a chargeable number that never respond.

0 Kudos
Reply