Menu
Reply
  • 5
  • 0
  • 0
Correy
Joining in
108 Views
Message 1 of 4
Flag for a moderator

No data connection

I had an Huawei Union and upgraded to a Coolpad illumina , I followed the process on the Virgin Mobile website to switch my service from the new phone to the old phone. As a result I can now text and talk on the new phone but yet no data connection. I've checked my settings in an attempt to find out why I can't get internet and I can't find anything. I have 4 bars but there is no 3G/4G/LTE icon beside. I've called customer care and they told me the cell towers were being upgraded which was the cause for the inconvenience and to wait 2-3 days. I don't believe this to be true I have been waited and still no data connection. And if that was the case then why would data on the old phone work and not the new one. It's the same plan, same service just different phone. Somebody please me.

0 Kudos
Reply
  • 1.61K
  • 181
  • 267
paulchambers061
Super solver
100 Views
Message 2 of 4
Flag for a moderator

Re: No data connection

  • 4.36K
  • 590
  • 1.21K
teabag
Community elder
98 Views
Message 3 of 4
Flag for a moderator

Re: No data connection

Your 1st post got moved to the mobile section, there are a couple of things on there you can try

https://community.virginmedia.com/t5/Virgin-Mobile/No-data-connection/m-p/3910946#M133316

 

---------------------------------------------------------------
BB 200 - Hub 3, Phone Talk w/ends, Mobile Sim only x2. Customer since 1993.
0 Kudos
Reply
  • 3.25K
  • 236
  • 191
Forum Team
Forum Team
75 Views
Message 4 of 4
Flag for a moderator

Re: No data connection

Hi Correy, 

Thanks for your post and welcome to our community. 

I'm really sorry that you're having issues with data at the moment, I can appreciate you're keen to get this sorted. 

So we can take a closer look at this for you I'll pop you a personal message and we'll take things from there. 

I look forward to hearing back from you soon. 

 

Emma_C - Forum Team
0 Kudos
Reply