Menu
Reply
Highlighted
  • 2
  • 0
  • 0
jlstevo
Just joined
184 Views
Message 1 of 4
Flag for a moderator

No 4G

Hi, I was recently sent a new 4G SIM for my Lenovo P2 phone for an upgraded contract, I replaced the old SIM and received the text to confirm the switch was successful and my old SIM was no longer active. However with wifi turned off and mobile data turned on there is no internet connection available on any apps. My old SIM did have working 4G data however.

0 Kudos
Reply
  • 3.29K
  • 448
  • 857
Very Insightful Person
Very Insightful Person
174 Views
Message 2 of 4
Flag for a moderator
Helpful Answer

Re: No 4G

Probably your APN settings need updating

Have a look at this thread

https://community.virginmedia.com/t5/Virgin-Mobile/New-Purple-Virgin-Mobile-SIM-and-need-the-APN-set...

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

0 Kudos
Reply
  • 2
  • 0
  • 0
jlstevo
Just joined
163 Views
Message 3 of 4
Flag for a moderator

Re: No 4G

Thanks, turns out entering the combined APN settings did fix the issue.
One thing to note it was mentioned there at the bottom to "Leave all other options blank/Not set", however if I set the "Bearer" field to Unspecified 4G would not work, it needed to be set to LTE to work.

0 Kudos
Reply
  • 3.29K
  • 448
  • 857
Very Insightful Person
Very Insightful Person
160 Views
Message 4 of 4
Flag for a moderator

Re: No 4G

Thanks for that information.

I think some androids work and others don't for reasons beyond my comprehension 

 

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

0 Kudos
Reply