Menu
Reply
Highlighted
  • 6
  • 0
  • 0
silvermercf1
Joining in
1,364 Views
Message 1 of 10
Flag for a moderator

New 4G data only sim for my car is recognised but will not connect

New 4G data only sim for my car is recognised as a Virgin sim but will not connect. The same card works in my iPhone 5s no problem. My phone/ data 4G sim from my iPhone 5s when inserted in my car works the data in my car no issues. Why will the data only card not connect when inserted in the car?

0 Kudos
Reply
  • 272
  • 22
  • 43
caravanj
Fibre optic
1,462 Views
Message 2 of 10
Flag for a moderator
Helpful Answer

Re: New 4G data only sim for my car is recognised but will not connect

Are you wanting to use the data-only SIM card for the Mercedes Me functions?

0 Kudos
Reply
  • 6
  • 0
  • 0
silvermercf1
Joining in
1,357 Views
Message 3 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

It is for use in a Range Rover in command system. The system is 3G.

0 Kudos
Reply
  • 272
  • 22
  • 43
caravanj
Fibre optic
1,427 Views
Message 4 of 10
Flag for a moderator
Helpful Answer

Re: New 4G data only sim for my car is recognised but will not connect

Not sure about Range Rover but for the Mercedes you have to register the car's VIN with the dealer to get the Mercedes Me command online system function working.

Can you check / change the APN settings in your Range Rover?

0 Kudos
Reply
  • 6
  • 0
  • 0
silvermercf1
Joining in
1,340 Views
Message 5 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

It is a new Range Rover and the dealership has register the vehicle. I have contacted the Land Rover dealership who has not been very helpful. Their response was perhaps you need a 3G card but I am not very technical. Not the response I was after when I have just spent £87,000 on a new car.

 

0 Kudos
Reply
  • 272
  • 22
  • 43
caravanj
Fibre optic
1,326 Views
Message 6 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

I'd take the car to the dealer, give them the SIM card & say "get it working, that's why I've paid you £87,000".

If they were lucky & I was in the right mood they might get a "please". thrown in for free. 

If they can't sort it I'd insist that they got a vehicle media installer to fix it at their expense.

Not ever likely to own a Range Rover, my knowledge of them & their features is limited but the link may help you if it's talking about the same features.

https://www.velarforums.co.uk/viewtopic.php?t=275

0 Kudos
Reply
  • 6
  • 0
  • 0
silvermercf1
Joining in
1,320 Views
Message 7 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

Hi caravanj

your comment about resetting the APN made me rethink and set me down the correct path. Although the system read the sim as a Virgin network it did not automatically connect as suggested by the Land Rover dealership. You still have to turn off auto network and select add a new network. Enter “Virgin” for the network, enter your “username” and “password” for Virgin mobile then hit “connect. Sorted.

Thanks

0 Kudos
Reply
  • 272
  • 22
  • 43
caravanj
Fibre optic
1,316 Views
Message 8 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

That's great news.

Now enjoy your new car.

0 Kudos
Reply
  • 6
  • 0
  • 0
silvermercf1
Joining in
1,311 Views
Message 9 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

Thanks caravanj

i did take the car back to the dealership. They booked the car in, in a weeks time. Their thought was I must have put the SIM in the wrong way around and damaged the card reader. No one could spare the time to get off their backside and walk the 20 yards to the front door and have a look.

Love the car but Land Rover dealerships *#@**#@

 

0 Kudos
Reply
  • 1
  • 0
  • 1
daimiles
Joining in
1,093 Views
Message 10 of 10
Flag for a moderator

Re: New 4G data only sim for my car is recognised but will not connect

I had the same problem.

Problem
When inserted into my Velar, a Virgin Mobile 4G data only SIM is apparently recognised as a Virgin SIM but will not connect. The same card works in my and my wife’s iPhones with no problem. Virgin Mobile 4G SIMs from my and my wife’s iPhones work when inserted in our Velar with no issues. For some reason the data only Virgin SIM would not connect when inserted in the Velar. A new data SIM was sent by Virgin but the problem persisted.

Attempts at problem resolution
After several calls to Virgin Mobile, and after being passed from pillar to post, I eventually spoke to someone who said that the problem was that prior to the end of 2017 Virgin had been using Virgin-branded ‘white’ EE SIMs. However from the start of 2018, they had been issuing ‘purple’ SIMs made specifically for Virgin. The new SIMs were not being recognised by the Range Rover server as the Range Rover system had not been updated to automatically recognise ‘purple’ Virgin SIMs.

I rang Range Rover and a very attentive man took the details, understood the issue and said that he would need to speak to his manager about the resolution to the problem. However, after about 5 minutes he came back saying, “I’m sorry but as this problem has not disabled your vehicle, we cannot help.” - a not very customer-focused response.

Since then I have been fiddling around and have found a solution to the problem.

Solution
Insert the Virgin Data SIM into the slot in the central armrest of the Velar.
Go to <Settings>, <All settings>, <Connectivity>, <Mobile Network>, turn off <Auto network> and select <Add a new network>.
Type in “Virgin” for the network, after which one is prompted to enter “Username” and “Password”
Enter the <Username> and <Password> for your Virgin Mobile account.
Hit <Connect>.

In the absence of Range Rover/Virgin Mobile taking action so that 'purple' SIMs are recognised, this worked for me