Menu
Reply
  • 1
  • 0
  • 0
kayem
Settling in
634 Views
Message 81 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

I too am having this issue. New sim, new phone. Everything working except the data. I've set up the APN as per the helpful instructions on this thread, but with no joy. I've also had a useless conversation with Customer "Service". Anyone else out there got any ideas until I get into a virgin shop?

Thanks

0 Kudos
Reply
  • 26
  • 0
  • 5
pbarrett
On our wavelength
621 Views
Message 82 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Just out of interest, when it was re-registered, did you get a new text message asking you to accept/install the (new) config. settings ?

0 Kudos
Reply
  • 2.18K
  • 279
  • 511
enlli
Problem sorter
615 Views
Message 83 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Please don't accept the APN settings being sent by Virgin as being correct

Use the ones in the thread at the top of the forum or as outlined in this thread.

0 Kudos
Reply
  • 26
  • 0
  • 5
pbarrett
On our wavelength
609 Views
Message 84 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Indeed Enlii, but I was just wondering if they had changed the settings in the text/config. script. as they should have done by now.

0 Kudos
Reply
  • 2.18K
  • 279
  • 511
enlli
Problem sorter
599 Views
Message 85 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Easy enough to check on the phone and compare

MNC30 should stand out in the old one. It's 38 in the new

0 Kudos
Reply
  • 9
  • 1
  • 1
kelvinlewisik1
Tuning in
397 Views
Message 86 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Doesn't save on my S7!!!!
0 Kudos
Reply
  • 469
  • 39
  • 69
paulchambers061
Fibre optic
393 Views
Message 87 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Click the 3 dots top right and select save?
0 Kudos
Reply
  • 1
  • 0
  • 0
weeties101
Joining in
334 Views
Message 88 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Similar problem here.

1. Had a Virgin Mobile SIM card in my old Galaxy Note 2. Worked fine (3G only).

2. Galaxy Note 2 died. Put SIM card in new, generic Android phone (Blackview BV7000 Pro). 3G worked fine.

3. Switched to 4G. Got a new SIM card, put that in my Blackview phone. 4G worked fine.

4. Got sold a cheaper package by Virgin. Got a new SIM card. Can't get mobile data at all, and APN vanishes whenever I try to change the MNC from 38 to 30.

Tried the factory reset - no joy. Tried phoning customer support ("it must be the phone"). Tried the combinations of APN settings earlier in this thread (change MNC - APN vanishes. Don't change MNC - no data).

Any idea how I can get in touch with UK technical support? Now over a month with no data!

0 Kudos
Reply
  • 3K
  • 361
  • 811
teabag
Trouble shooter
328 Views
Message 89 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

The MNC needs to be 38 for these new SIM's.
http://community.virginmedia.com/t5/Virgin-Mobile/New-Purple-Virgin-Mobile-SIM-and-need-the-APN-sett...
If the APN matches these settings and still not working, ask CS to check mobile data is switched on OK their end or try refreshing it.
---------------------------------------------------------------
BB 200 - Hub 3, Phone Talk w/ends, Mobile Sim only £9 and £8 sims. Customer since 1993.
0 Kudos
Reply
  • 4
  • 0
  • 1
upthehatters
Tuning in
106 Views
Message 90 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Hi,

i have a similar problem with my sim. i got sent out a purple 4G sim, im on a rolling 30 day contract. i put in the settings Virgin sent me via text, tried them and they didnt work. i restarted my phone and it connected when it re booted the mobile data kicked in (however when the phone started up i had no signal it took about 15 seconds for the signal to kick in). turned the data off, then about an hour later turned it back on again, didnt work. left it on for about 4 hours, nothing came up, couldnt get mobile data. switched the phone off and back on, and it worked. i cant keep turning my phone off and on when i need mobile data, so am i missing something i should be doing? any help would be appreciated. i have phoned up 789 numerous times, but all they do is send me new apn settings. it was fine on the red sims, but since i have had the 4g purple ones its been a nightmare. its been like this for over 2 weeks now.

0 Kudos
Reply