Menu
Reply
  • 41
  • 0
  • 6
GRC
On our wavelength
3,195 Views
Message 11 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

I have a similar problem with 4G on Blackberry Z10s and Leap.  I have new 4G SIMs for 3 phones and while I get data the phone will not set to 4G, reverting to 2G/3G, i.e. 4G & 3G becomes 3G; 4G & 3G & 2G becomes 3G & 2G.  The phones use band 1,3,7,8 and 20 (Leap) and similar on the Z10, which I understand should mean they pick up the VM 4G.  I have been in 3 or 4 different geographic location rom Wiltshire to Kent to Warwickshire and the same thing happens.  VM phone team have been summarily unhelpful thus far.  PN is set to goto.virginmobile.uk. Any thoughts?

0 Kudos
Reply
  • 57
  • 4
  • 7
Assassin
Dialled in
3,166 Views
Message 12 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

I've also got a blackberry passport and im having trouble getting a 4G signal.

Same thing happens to my device I have rung up and cannot get 4G signal.

Hopefully this will be resolved soon.

  • 41
  • 0
  • 6
GRC
On our wavelength
3,156 Views
Message 13 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

My colleague has a Leap like me but we use Vodafone at work.  He gets 4G and can set the phone to 4~G etc in settings as you would expect. Most frustrating but suggests it is a VM issue, not BB.  And I was in central London in a room on the roof of a 4 floor building so brilliant signal strength

0 Kudos
Reply
  • 57
  • 4
  • 7
Assassin
Dialled in
3,139 Views
Message 14 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Yes its not a blackberry issue as I tried this on my friends Iphone 7 Plus and Android (Samsung)

Both phones could not get a 4G signal at all. Phoned virgin customer support and they can only

recommend a sim refresh but this does not resolve the issue. I believe its due to virgins network settings that need to be updated.

I'm hoping this will get resolved soon as I have upgraded to a 4G plan and have been unable to get it since switching

0 Kudos
Reply
  • 41
  • 0
  • 6
GRC
On our wavelength
3,119 Views
Message 15 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

I called them today as well.  They said (again) that they need to do something to my account at their end and they will call me back today still (still waiting at 7pm).  I have rebooted the phone but no change (yet?)

0 Kudos
Reply
  • 209
  • 6
  • 20
Forum Team
Forum Team
3,086 Views
Message 16 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Hi GRC and Assassin,

Thanks both for posting regarding your experiences with 4G.

Regarding what you have both posted, it does seem like you do have slightly different issues.

However I would like to spend some time investigating them and will shortly send each of you PM's with further details.

Look forward to hearing from you both.

Regards

Liam

Liam_T
Forum Team

Who's who? Find out more about our community members. Good folk to know


0 Kudos
Reply
  • 32
  • 0
  • 3
Schpengle
Tuning in
3,013 Views
Message 17 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Hi there, just saying, exactly the same problem as GRC on a Blackberry Z10. 
I cant get it 4G to stick, in fact, I cant get any better than H for a network speed. This is only my 2nd day on the network, but. this fabled 4G does not seem to be fully functioning. I am in an area of Excellent Coverage apparently, but it would appear not with my phone as, it does as stated here, reverts back to 3G 2G signal. it will not stay on 4G.

I have now just gone back onto my old Tesco Sim card, with its 02 network provider and BANG. straight to H+ - although I have seen 4G (on rare occasions- so possible) and LTE prior to an BB OS upgrade quite some time ago. I am now connected via the old Tesco sim at H+. This rate is not possible with the new VM one as the VM SIm sticks at H and thats my lot! as quoted here

http://community.virginmedia.com/t5/Virgin-Mobile/Blackberry-Passport-NO-4G-signal-available-APN-set...

where Assassin has also posted,
it is the the new £15, 20GB offer.

I kind of know my way around some of this stuff, but something appears cranky with the APN or the SIM Settings as on other networks, SIMS, not an issue.

Ive done the the Online Live chat thing and confirmed that my account is active for 4G.  I would phone but.. I don't think I could handle struggling to understand the accent for the fault finding instructions. Buying the SIM was enough for me!


OK let me know how it goes and, like the others here, if a Virgin member would like to PM me, in order to root around the settings, fire away Smiley Happy

0 Kudos
Reply
  • 32
  • 0
  • 3
Schpengle
Tuning in
3,008 Views
Message 18 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

EDIT!
After turning phone off , swapping back to the new VM sim, BOOSH!
4GLTE!! - er, Momentarily! as it was booting.
then, back to H, where it is, once again parked.

I have found, with Tesco/O2 network for instance, that there can be lousy data coverage. However, if I connect this phone with the Tesco sim to ANOTHER network provider (any!) via a manual scan, It will connect, but warn me SOS calls only. I then manually scan again, swap BACK to Tesco and ,BANG, H+ when I reconnect. it Jiggles something Smiley Happy

SO, i tried this with VM sim, several times, no difference. however, going Back to the O2 sim, phone turned off, then back on and yes, 4GLTE, for 1 or 2 seconds then gone.

I shall continue to experiment while I await someone getting back to me.

 

Yep, something is definitely FUBAR with this VM sim service as it shows ALL NETWORK SERVICE providers as either UMTS or GSM -Nothing more. it doesnt recognise ANY of them as providing anything higher! even though with the Tesco sim , I can view the networks and see which is 4G, 3G, GSM etc.
So, it is definitely something wrong with the SIM and its APN Connection settings, as once the SIM is inserted, all network providers appear equally as bad, if not worse than VM.

This sim appears to be incapable of Recognising anything greater than UMTS, GSM on ANY network, let alone the one I'm paying for.

Interesting marketing strategy too Smiley Happy

0 Kudos
Reply
  • 32
  • 0
  • 3
Schpengle
Tuning in
2,996 Views
Message 19 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

Or, possibly my Account isn't allowed to View/Access 4G networks. even though they say I can. and I pay for it.
But it does show the other networks as being 3G capable.
well, as UMTS. odd choice of descriptor.
interesting.

0 Kudos
Reply
  • 32
  • 0
  • 3
Schpengle
Tuning in
2,982 Views
Message 20 of 98
Flag for a moderator

Re: New 4G SIM, But No Data Connection

And another oddity on my account- I am looking at securing my WiFi with a VPN. However, whenever I try to view those site, I am told that I have parental controls are enabled on my account. So, I disabled them. It still wouldn't view the pages. So, I tried a *Proper* adult site. It allowed that! I then went back to vpn site. I could now view. That was the early hours of this morning.

This is the afternoon and I am now looking at VPNs again.
Guess what?
It tells me I have Adult controls activated! I have logged in and checked them. nope.

I am now on the phone to tech support like many of you, I have been advised to enable and disable parental controls, then reboot the phone. I shall do this shortly.

But something is definitely wrong with the account settings.

They say I have 4G enabled - I am unable to view this level on ANY provider - like a PAYG sim
They say I have Parental controls turned off.

Both of the above are incorrect. So what else is incorrect with the settings?
Has anyone else with 4G connection issues tried enabling/disabling parental controls? do these?

UPDATE! well, that was productive!
A very helpful tech support guy on the phone, just spent an hour with him, he came here, he read the Entire thread, I explained all the weird Sim in/Out, shake it all about stuff and he thinks he might be onto a solution.
He has emailed their BackOffice with a complaint and raised a ticked based on my explanations above and what he thinks it might be and is calling back tomorrow, as well as sending a new SIM with a particular setting adjusted (to do with the OLD "Blackberry Services"- which OS10 no longer uses!) via 24 hour delivery and will call back tomorrow.

His explanation was very logical, and came to him after a very productive chat!

Here's to hoping guys Smiley Happy
0 Kudos
Reply