Menu
Reply
  • 5
  • 0
  • 0
jodles04
Joining in
115 Views
Message 1 of 4
Flag for a moderator

Imo go not working abroad

I brought a imo to use in France but I am not getting at internet. I have a constant red light. How can this be fixed. Roaming is on. I need internet asap. 

0 Kudos
Reply
  • 3.05K
  • 218
  • 175
Forum Team
Forum Team
70 Views
Message 2 of 4
Flag for a moderator

Re: Imo go not working abroad

Hi Jodles04, 

Sorry you're having issues with the IMO in France, I can appreciate you're keen to connect. 


I'm keen to have a look at the settings so I'll pop you a personal message and we'll take it from there. 

I look forward to hearing from you soon. 

Thanks Smiley Happy 

Emma_C - Forum Team
0 Kudos
Reply
  • 5
  • 0
  • 0
jodles04
Joining in
41 Views
Message 3 of 4
Flag for a moderator

Re: Imo go not working abroad

Still not working. I don't even have four lights - all I have is two green, a red and no light. I am now back in the UK and no one on the phone can help me with why this is happened. Tried factory reset, tried taking out battery, NOTHING WORKS!

No internet even though I am paying you for it, which I am not happy about at all.

Terrible customer service from those on the phone thus far...
0 Kudos
Reply
  • 290
  • 9
  • 14
Forum Team
Forum Team
19 Views
Message 4 of 4
Flag for a moderator

Re: Imo go not working abroad

Hi Jodles04, 

 

I am really sorry to hear you're having issues with your IMO. Have you managed to get this sorted since your post? If not please let us know and we will be more than happy to help you. 

 

Many thanks, 

Hetty_R
0 Kudos
Reply