Menu
Reply
Highlighted
  • 16
  • 1
  • 1
DickBranston
On our wavelength
438 Views
Message 1 of 5
Flag for a moderator

Disable "Advanced Network Search"... How?

Hello.  I'm on Virgin Mobile but do not have home Virgin Media broadband, I'm a mobile customer only.

If I type a duff URL in, e.g. http://www.fgfgfgfgfgfgfg.com, then I get a search page with a Virgin Media logo.  I don't want this, I just want an error page as it's confusing.  There's a link at the top that says...

This service is optional and you can switch it off here

But if I click on this I get the following message...

https://my.virginmedia.com/advancederrorsearch/hitch

Advanced Network Error Search

Our advanced network error search helps you find the website you're looking for quickly.

We all make mistakes when we type in website addresses. Perhaps we miss a few letters, or the website doesn't exist any longer. If an address you enter doesn't locate a site, this handy feature will convert the incorrect address into a web search, so instead of an error message you will get a list of our closest matches, plus some additional related links.

You can switch off this service, but you need to be connected to the internet via your home Virgin Media broadband connection. We cannot recognise this connection right now, or there may be a problem with our system. Please connect to the internet via your home broadband connection, or try again later.

The Virgin Media Team

It seems that I'm being blocked as I'm not accessing via my home broadband service.  But I don't have such a thing, I'm exclusively a mobile-only customer.

Is there an alternative way of changing this setting, without the nonsensical blocking?  Thanks.

0 Kudos
Reply
  • 2.4K
  • 76
  • 117
Forum Team
Forum Team
398 Views
Message 2 of 5
Flag for a moderator

Re: Disable "Advanced Network Search"... How?

Hi there, 

 

Thank you for your post. My apologies for any issues you're having.

 

Would you be able to confirm if you have our Virgin Media Connect app installed?

 

^Martin

0 Kudos
Reply
  • 3
  • 0
  • 0
danq
Joining in
329 Views
Message 3 of 5
Flag for a moderator

Re: Disable "Advanced Network Search"... How?

I'm seeing the same problem (fresh post here). Here are some example steps to reproduce it:

  1. Be connected via cellular data on a Pay Monthly Virgin Mobile device.
  2. Visit an invalid domain using a web browser (e.g. sdfjhokladfshdflkhkjsadhfkldfskjhakulsdfh.com)
  3. You should see a "server not found" message from your browser. Instead, you'll see a Virgin Mobile page from "Advanced Network Error Search".
  4. At the top of the page is the message "This service is optional and you can switch it off here", with a link to https://my.virginmedia.com/advancederrorsearch/hitch
  5. It should be possible to disable the service from this page. Instead, the page says that it only applies to Virgin Broadband services (and not to Virgin Mobile).

If you could advise how I can fix it, too, that'd be appreciated.

0 Kudos
Reply
  • 16
  • 1
  • 1
DickBranston
On our wavelength
316 Views
Message 4 of 5
Flag for a moderator

Re: Disable "Advanced Network Search"... How?

Interestingly, since I started this thread things have changed.  I'm now using a laptop connected to the phone's wifi hotspot and have set it to use Google's own DNS instead of Virgin's.  This alone does disable the VM hijacking thing, as it makes them unable to substitute the page for their own.  I expected this.

What I didn't expect is that, when using Google's DNS, clicking that link above to switch it off now functions correctly.  So I've disabled it using the computer that uses google's DNS, at which point it told me that it was already off (even though this was the first time I successfully used it).

After doing this, if I now enter an invalid URL on my phone's own browser I don't get the VM hijack page.  Using an alternative DNS on an android phone isn't even possible for its own cellular service, so it has to be using VM's DNS.  I haven't tested it, but I'd assume that any PC's using VM's own DNS will also now function normally too.

So it appears that my issue is resolved.  I don't know whether this is because I used the alternative DNS or perhaps because VM have fixed it but, for whatever reason all is well here for now at least.

0 Kudos
Reply
  • 16
  • 1
  • 1
DickBranston
On our wavelength
312 Views
Message 5 of 5
Flag for a moderator

Re: Disable "Advanced Network Search"... How?

A further note...

I've just switched my PC back to VM's own DNS and confirm that the link above that should disable it now gives the error message as before.

But... even while using VM's DNS I no longer get hijacked if I enter an invalid URL, I get the standard browser error message instead.

So... the solution is to use an alternative DNS to switch it off, after which it gets disabled for VM's DNS too.

This is a weird solution but it appears to work, hopefully permanently.

0 Kudos
Reply