Menu
Reply
Highlighted
  • 4
  • 0
  • 0
ChrisKManc
Joining in
302 Views
Message 1 of 3
Flag for a moderator

Netflix not working on new TiVo box

Hello, 

I've recently had virgin installed and have a TiVo box. When I watch Netflix it crashes after only about 5-10 minutes. I get the message 'we're having trouble playing this title at the moment. Please try again or select a different title'. When I go to log back into the system I get the message 'There was a problem connecting to the virgin media service (C130). Some options will not be available until this issue is fixed. Please try connecting to the virgin media service again.'

This is very frustrating. I've tried restarted both the router and TiVo box, and also tried disconnecting the ethernet cable, still no joy.

Any help would be very welcome.

Many thanks

Chris 

0 Kudos
Reply
  • 1.32K
  • 73
  • 119
Forum Team
Forum Team
258 Views
Message 2 of 3
Flag for a moderator

Re: Netflix not working on new TiVo box

Hi Chris,

 

Thank you for reaching out to us via our community.

 

Are you still having the same issue?

 

Have you tried plugging the Ethernet into a different port ?

 

Tried a different cable?

 

Done a reboot on both router and Tivo box, unplugging from the wall?

 

 

Kind regards

 

Paul.

 

  

0 Kudos
Reply
  • 4
  • 0
  • 0
ChrisKManc
Joining in
210 Views
Message 3 of 3
Flag for a moderator

Re: Netflix not working on new TiVo box

Hi Paul,

Many thanks for the suggestions. 

I’ve tried all of those and still no luck. Still having the same issues. 

Many help you could give would be very much appreciated. Netflix works fine when played through my Xbox by the way. Not ideal and really need TiVo box to be working. 

 

Thanks

Chris

0 Kudos
Reply