Menu
Reply
  • 2
  • 0
  • 0
SlowSpeedBlues
Joining in
281 Views
Message 1 of 5
Flag for a moderator

Anyone else got pixelating TV picture?

TV picture often pixelating. Why?

Engineer came with new router for crap WiFi. 

Said he'd sort out new tv box for us. But it never happened.

But will this help us or not? 

0 Kudos
Reply
  • 8.09K
  • 427
  • 1.15K
PrinterElf
Alessandro Volta
237 Views
Message 2 of 5
Flag for a moderator

Re: Anyone else got pixelating TV picture?

If it's on live TV, you may have signal issues.

If it's on recordings only, then your box may not be long for this world.

You can check to see if there are any reported service issues in your area using this link: http://my.virginmedia.com/faults/service-status

If it's not an area fault then the system will perform a few tests of your installation to see if there's anything obvious.

0 Kudos
Reply
  • 2
  • 0
  • 0
SlowSpeedBlues
Joining in
235 Views
Message 3 of 5
Flag for a moderator

Re: Anyone else got pixelating TV picture?

Time for more calls to virgin 😔

0 Kudos
Reply
  • 3
  • 0
  • 0
Oapdub
Joining in
223 Views
Message 4 of 5
Flag for a moderator

Re: Anyone else got pixelating TV picture?

Yes!

I've just come on here to post about this problem. The last couple of months the picture has been pretty ropey for the most part. Its quite annoying!

Just tried the link on this thread to test things and that flags no problems.

Can it be fixed by replacing with a new box?

Ta.


@SlowSpeedBlues wrote:

TV picture often pixelating. Why?

Engineer came with new router for crap WiFi. 

Said he'd sort out new tv box for us. But it never happened.

But will this help us or not? 



@SlowSpeedBlues wrote:

TV picture often pixelating. Why?

Engineer came with new router for crap WiFi. 

Said he'd sort out new tv box for us. But it never happened.

But will this help us or not? 


 

0 Kudos
Reply
  • 8.09K
  • 427
  • 1.15K
PrinterElf
Alessandro Volta
219 Views
Message 5 of 5
Flag for a moderator

Re: Anyone else got pixelating TV picture?


@Oapdub wrote:

Yes!

I've just come on here to post about this problem. The last couple of months the picture has been pretty ropey for the most part. Its quite annoying!

Just tried the link on this thread to test things and that flags no problems.

Can it be fixed by replacing with a new box?

Ta.


If this is the case on all channels, then it's a signal issue, which will need a tech visit. If it's only present on recording then it's a dying HDD within the box, which you may be able to swap yourself, but likely also will need a tech visit.

0 Kudos
Reply