Menu
Reply
  • 50
  • 2
  • 4
Roger_K
Dialled in
1,173 Views
Message 1 of 13
Flag for a moderator

Registered Devices

I have a Windows PC browser and my Android phone registered for TV Go but when I try to use TV Go on my phone it tells me to register. It then says I can’t because I already have two devices registered, namely the phone in question and the PC browser. This is confirmed by the TV website’s “Device Management”.  Could someone please reset my devices so I can start again?

0 Kudos
Reply
  • 9.51K
  • 397
  • 527
Forum Team (Retired) Rose_B
Forum Team (Retired)
1,120 Views
Message 2 of 13
Flag for a moderator

Re: Registered Devices

Hi Roger_K,

Welcome to the community.

I'd like to take a look into this for you so I'm just going to send you a private message which you will find if you click on the purple envelope at the top right of the screen.

Talk to you soon

Rose
Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 50
  • 2
  • 4
Roger_K
Dialled in
1,115 Views
Message 3 of 13
Flag for a moderator

Re: Registered Devices

Much appreciated Rose, I have sent you a private message reply.
Roger
0 Kudos
Reply
  • 9.51K
  • 397
  • 527
Forum Team (Retired) Rose_B
Forum Team (Retired)
1,097 Views
Message 4 of 13
Flag for a moderator
Helpful Answer

Re: Registered Devices

Thanks Roger,

Please check your inbox and get back to me when you can.

 

Rose
Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
  • 50
  • 2
  • 4
Roger_K
Dialled in
1,086 Views
Message 5 of 13
Flag for a moderator

Re: Registered Devices

Thanks Rose I have now registered my devices.
0 Kudos
Reply
  • 9.51K
  • 397
  • 527
Forum Team (Retired) Rose_B
Forum Team (Retired)
974 Views
Message 6 of 13
Flag for a moderator

Re: Registered Devices

Hi Roger,

That's great and if you have any further issues please let us know on the community.

Take care

Rose
Forum Team


New around here? To find out more about the Community check out our Getting Started guide


0 Kudos
Reply
Highlighted
  • 2
  • 0
  • 0
craigh2150
Settling in
932 Views
Message 7 of 13
Flag for a moderator

Re: Registered Devices

Hi,

I had the same issue. My registered devices have been the same two devices for several months now. I went to log in on my phone the other day and it said it was not a registered device. I thought the best option was to delete the device registered for my phone and just reregister the same phone. That worked fine.
Now I have logged in on my pc and it is flashing up with the same error saying that it isnt a registered device even when it is one of my registered devices. Unfortunately it is now telling me that I cant change or update my devices again until the start of the new month. Any help would be appreciated.

Thanks,

Craig

0 Kudos
Reply
  • 1
  • 0
  • 0
Timboevo
Just joined
878 Views
Message 8 of 13
Flag for a moderator

Re: Registered Devices

Hi. I also have the same problem. Please help

0 Kudos
Reply
  • 9.22K
  • 381
  • 633
Forum Team (Retired) Collette_O
Forum Team (Retired)
776 Views
Message 9 of 13
Flag for a moderator

Re: Registered Devices

Hi Timboevo,

Welcome to the community.

I just wanted to pop by and see if you're still having the same issue today?  If so, let me know and I can help further.

Collette.


Tech fan? Have you read our Digital life blog yet? Check it out


0 Kudos
Reply
  • 2
  • 0
  • 0
sharondale
Joining in
708 Views
Message 10 of 13
Flag for a moderator

Re: Registered Devices

Same problem here.  A device (this laptop) was working fine last week, but is asking to register a new device today.

0 Kudos
Reply