Menu
Reply
  • 2
  • 0
  • 1
Exilelbue
Joining in
227 Views
Message 1 of 4
Flag for a moderator

Registerd Devices

I have done fresh installs of Windows 10 1809 on my two registerd devices. Now I'm informed I have to wait 30 days until I can register them. Since they were registered over 6 months ago why ?

Any advice/help please with this as I cannot bare the idea of calling Virgin support for this.

Cheers.

0 Kudos
Reply
  • 223
  • 2
  • 13
Moderator
Moderator
207 Views
Message 2 of 4
Flag for a moderator

Re: Registerd Devices

Hi, Exilelbue.

 

Welcome to the community 🙂

 

Sorry that you're having issues, can I confirm this is with TVGo? If so, our support team is aware of the ongoing issue and is working on getting this sorted.

 

Of course if this is regarding TVGo and you're available, we can do this via online chat. Please click the link to get in touch with our webchat team.

 

If there's anything else I can help with plesae let me know.

 

Chai_S

The do's and don'ts. Keep the community welcoming for all. Follow the house rules


  • 2
  • 0
  • 1
Exilelbue
Joining in
190 Views
Message 3 of 4
Flag for a moderator

Re: Registerd Devices

Hey Dave_DW just to let you know one of your colleagues has resolved my issue, many thanks for your help and prompt response.

  • 106
  • 1
  • 3
Forum Team
Forum Team
187 Views
Message 4 of 4
Flag for a moderator

Re: Registerd Devices

Hi, Exilelbue

 

I'm happy to know that this has already been sorted. 🙂

 

Feel free to reach to us for any help.

 

Kind Regards,

Chai_S

0 Kudos
Reply