Menu
Reply
Highlighted
  • 3
  • 0
  • 0
Hannahknight
Joining in
436 Views
Message 1 of 7
Flag for a moderator

Slow wifi

  • Hi my hub 3 WiFi is really slow I am only getting 8mbps I'm on 350 package  when it's wired I get full speed  
0 Kudos
Reply
  • 26.23K
  • 1.11K
  • 4.32K
Very Insightful Person
Very Insightful Person
433 Views
Message 2 of 7
Flag for a moderator

Re: Slow wifi

your best bet is a better wifi router and modem mode

As a Very Insightful Person, I'm here to share my knowledge. I don't work for Virgin Media.

Click to learn more about VIP

Use Kudos to say thanks

Mark as Helpful Answer if I've helped

0 Kudos
Reply
  • 1.29K
  • 175
  • 535
Andruser
Knows their stuff
420 Views
Message 3 of 7
Flag for a moderator
Helpful Answer

Re: Slow wifi

But before you spend money on a high quality router, you may want to try and optimise the settings of your Hub 3, because whilst it is a deeply unimpressive beast, it is basically adequate.  Recycling content from a previous post of mine:  You'll need to log in to the hub interface through an internet browser, by typing 192.168.0.1 into the address bar.  I've set that up as a clickable link which might be easier, but may not work if your computer security settings are dialled up the max. You'll need to log in with the administrator password on the back or base of the hub (don't confuse these with the wifi details), and then go into settings. 

Now if you don't use a wireless guest network, turn that off - no point giving the hub more work to do than it needs.  Go to Advanced settings>Wireless>Guest network and click Disable, and Apply changes.

Now go to Advanced settings>Wireless>Security, and change the wifi network name for 2.4 GHz to something clear for you but unique for example only,  HKnet24, and change the 5 Ghz to HKnet5.   Wifi password can be left as is, or changed to something you select, but I recommend you keep it the same for both bands. Scroll down and Apply changes again.  At this point all your wifi connected devices will disconnect and need to be reconnected to the "new" wifi identities - always use the 5 GHz band if available on the device.  If you're editing the settings on a wireless device you'll need to reconnect to the new wifi, and then reconnect to the hub interface if you want to make further changes, but most of the other defaults should be OK.

You can also disable channel optimisation and select channels manually under Advanced settings>Wireless>Wireless signal, which means that you can then increase 5 GHz channel width, and this enables the highest possible wifi speeds with premium devices, but if you're new to this then I'd suggest leaving them alone, or at least try renaming the two bands first and always connecting to the 5 GHz band if the device supports that.  If you do decide to disable channel optimisation, remember not to change 2.4 GHz channel width - that's a near guarantee of making your 2.4 GHz wifi worse for a whole range of reasons.  As before, don't forget to Apply changes.

This should work perfectly once you've reconnected your devices.  If there's any problem that you can't resolve (eg a forgotten password), or wifi seems even worse than before, then you can always do a full hard reset of the router with the pinhole button on the back, and that brings it back to "out of the box" settings but that's a last resort that you shouldn't need.

0 Kudos
Reply
  • 3
  • 0
  • 0
Hannahknight
Joining in
402 Views
Message 4 of 7
Flag for a moderator

Re: Slow wifi

Yeah that's made a difference  it's gone to 25mb on both 5g and 2g   is that normal   I'm getting 100 signal and testing speed on multiple  devices 

0 Kudos
Reply
  • 3
  • 0
  • 0
Hannahknight
Joining in
381 Views
Message 5 of 7
Flag for a moderator

Re: Slow wifi

Screenshot_20**:**:**:**:**:**.png

0 Kudos
Reply
  • 1.29K
  • 175
  • 535
Andruser
Knows their stuff
225 Views
Message 6 of 7
Flag for a moderator

Re: Slow wifi

"it's gone to 25mb on both 5g and 2g   is that normal   I'm getting 100 signal and testing speed on multiple  devices "

Sounds better, but 25 Mbps is only normal for a run of the mill device some way from the hub, connected to 2.4 GHz. 

I'm on a 200 Mbps connection, and I can get 190 Mbps close to the hub over 5Ghz, and 90 Mbps at the furthest indoor point, and 90/56 Mbps on the same basis with 2.4 GHz with a premium device, although down as low as 15-20 with an old Galaxy S3 connected to 2.4 GHz.  Low speeds are unfortunately common on 2.4 Ghz because there's usually a lot of overlapping signals, but for a range of technical reasons this doesn't apply to 5 GHz, and in my view you should be seeing much higher peak speeds if you're trying across a range of different devices and on 5 GHz.

Is the hub somewhere that the signal is blocked, for example behind a metal filing cabinet, or in a corner with a huge TV and pile of consumer electronics in front of it?  Or is the layout or construction of the property unfavourable, such as solid internal walls, or such that the hub is almost always a long way from the devices you're using?

 

0 Kudos
Reply
  • 11.8K
  • 1.08K
  • 2.56K
griffin
Alessandro Volta
215 Views
Message 7 of 7
Flag for a moderator

Re: Slow wifi

How are you testing the speeds?
What devices are you testing with?

I would disable connect automatically on the 2.4GHz band on your dual band devices to help prevent them roaming.

Downloading a wireless scanner like InSSIDer or Wifi Analyser for Android to test the signal strength accurately.
Testing1 meter from the Hub would give a good idea of the Hub's wireless output, assuming that the Hub is an open position as Anduser has advised and you have a clear line of sight
It would be useful to note the number of neighbouring networks using the same wireless channel.

 

0 Kudos
Reply