Menu
Reply
Highlighted
  • 4
  • 0
  • 0
JakeRogowsky
Joining in
227 Views
Message 1 of 5
Flag for a moderator

Slow wifi connection

Wifi and Ethernet connections seem fine in the living room where my router is. I get around 200 mbps. However, in my bedroom which is maybe 10 metres from the router I seem to only receive below 10mbps on my iPhone. Although, on my laptop in the bedroom I get around 120 mbps. Does anyone know why I am receiving such low connection on my iPhone only? It struggles to load things on my phone.

Thanks.

0 Kudos
Reply
  • 1.13K
  • 158
  • 474
Andruser
Knows their stuff
186 Views
Message 2 of 5
Flag for a moderator

Re: Slow wifi connection

Various possible causes, I'd guess your phone is connecting to the 2.4 GHz band and is getting a weak or heavily interfered wifi signal as most probable cause.  

Make sure your hub has got different names (SSID) for the 2.4 and 5 Ghz bands (for convenience use the same password), and then make sure your phone connects to the 5 GHz band.  If you're in hub settings, it may be useful to increase the channel width for the 5 GHz wifi, but do not touch channel width on the 2.4 GHz band.  Turn off automatic channel optimisation, and if you don't use it, turn off the guest network.  If you change the network name, you'll need to reconnect all wifi devices - they won't recognise the network.

You could also try changing the 2.4 GHz channel number (choose 1, 6, or 11) but only do this if you've got a wifi analyzer app on your phone to check for which channels have the strongest competing signals.

0 Kudos
Reply
  • 4
  • 0
  • 0
JakeRogowsky
Joining in
179 Views
Message 3 of 5
Flag for a moderator

Re: Slow wifi connection

Thanks for the reply and information. Where do I change all these settings? And also add a 5ghz WiFi too?

’sorry, new to setting up wifi and virgin in general’

Thanks.

0 Kudos
Reply
  • 1.13K
  • 158
  • 474
Andruser
Knows their stuff
162 Views
Message 4 of 5
Flag for a moderator

Re: Slow wifi connection

You'll need to log in to the hub interface through an internet browser, by typing 192.168.0.1 into the address bar.  I've set that up as a clickable link which might be easier, but may not work if your computer security settings are dialled up the max.  You already have a 5 GHz wifi signal active, but due to a dubious choice of defaults, the hub broadcasts both 2.4 and 5 GHz signals with the same name, and that's a recipe for confusing some devices.

You'll need to log in with the administrator password on the back or base of the hub (don't confuse these with the wifi details), and then go into settings.  I'll assume you're using a Hub 3 (earlier hubs are similar in principle but menus may differ, so you should still be able to work it out if you've not got a Hub 3).

Got to Advanced settings>Wireless>Wireless signal, and change 5 GHz channel width to 20/40, then scroll down the page and click Apply changes.  This means that premium devices using the 5 GHz band may be able to transfer data faster, though older and cheaper devices may not be able to take advantage.  Don't touch channel width on 2.4 GHz, that will worsen performance.

Now if you don't use a wireless guest network, turn that off - no point giving the hub more work to do than it needs.  Go to Advanced settings>Wireless>Guest network and click Disable, and Apply changes.

Now go to Advanced settings>Wireless>Security, and change the wifi network name for 2.4 GHz to something clear for you but unique for example only,  Jakenet24, and change the 5 Ghz to Jakenet5.   Wifi password can be left as is, or changed to something you select, but I recommend you keep it the same for both bands. Scroll down and Apply changes again.  At this point all your wifi connected devices will disconnect and need to be reconnected to the "new" wifi identities - always use the 5 GHz band if available on the device.  If you're editing the settings on a wireless device you'll need to reconnect to the new wifi, and then reconnect to the hub interface if you want to make further changes, but most of the other defaults should be OK. Personally I disable channel optimisation and select channels manually, but if you're new to this then I'd suggest leaving them alone.

This should work perfectly once you've reconnected your devices.  If there's any problem that you can't resolve (eg a forgotten password), then you can always do a full hard reset of the router with the pinhole button on the back, and that brings it back to "out of the box" settings but that's a last resort that you shouldn't need.

 

  • 4
  • 0
  • 0
JakeRogowsky
Joining in
149 Views
Message 5 of 5
Flag for a moderator

Re: Slow wifi connection

Damn, thank you so much. I’ll try me best to work through all of this and see if it makes a difference.

0 Kudos
Reply